SRCDS Steam group

[resolved] HLDSUpdateTool Keeps launching Gui Server 2008
Hello All,
I have run many Source based servers in the past. I am alos currently running a few on Server 2K3 and Windows 7.

I just setup a new VM with Server 2008 and I plan to migrate to this larger box. However, I am running into an issue that either I am terrible at describing and cannot find an answer for or I am missing the most obvious thing and that is why this is happening to me.

Server OS: Windows Server 2008 R2 64 bit
Processor: Dual Quad Xeon E5405s 2.00Ghz
Ram: 8GB
Game(s): I will be installing TF2 and CSS on this system
Full Install Command:
cd \
cd HLServer
HldsUpdateTool.exe -command update -game "Counter-Strike Source" -dir .

Typical Home Network: [Server] --> [Switch] --> [Switch] --> [Firewall] --> [Router] --> [Modem] --> [Internet]

This issue: When I attempt to run the install command it keeps bringing up the HLDSUpdateTool Gui instead of the normal command line driven installation where it starts to download all the files.

The HLDS tool is located in the same directory as with all of my previous servers too. I even installed another CSS server this morning on my Windows 7 box using the same commands and it worked as expected.

I have tried running the tool in XP compatibility mode, same issue.

Please tell me I am just fat fingering something or that in windows svr 2008 I have to do something special.

Thank you,

Update: I cannot leave well enough alone. In doing so I found the problem which honestly, I have never run into in all my years installing/updating Source servers. The stupid HLDS tool was either corrupt or was just not updating properly. I took the HLDStool directly from the Windows 7 PC and overwrote the one on my Windows Svr2008 install and I noticed...Replace a 637kb file with a 1.10MB file. At that point I knew it would work...and it did.

Hopefully some other DS like myself will stumble upon this thread and this can resolve their issue.

I also did try downloading the HLDS tool directly from the official site and an alternate location as well, just keep looking if it aint over a meg I guess. I thought it was supposed to update itself when you ran it the first time?

If you launch the program and it does not create the registry.blob you know something is up with the actual tool.


Forum Jump:

Users browsing this thread: 1 Guest(s)