SRCDS Steam group

TF2 MvM Dedicated Server problems...
For starters, I am very new to this site and VERY new to this sort of computer-y stuff. Me and my friends love to play the new TF2 MvM update, but we always had troubles getting into servers. So, I decided to try and make my own.
That said, I know perfectly find how to make a Listen/Local server. My ports are all forwarded and everything is taken care of. Then I came across what was called a "dedicated server" and became interested in it, because me and my friends would always lose the Listen server I created [this may just be the way they are-we don't really know] so, I dove right into trying to create one without any foreknowledge and utterly, horribly failed. Later, I saw this site and found the cool plugins for something called "Source Mod" and it got me trying to create dedicated servers again.
I've tried, and I've tried tirelessly for three days now, hopping from tutorial to tutorial, desperately trying to find SOMETHING that would help. I am on a Windows 7 computer, and I couldn't find any tutorials that were quite up-to-date with the new MvM.
I found one that was helpful, it helped me set up the hldsupdatetool correctly [I assume...] in c:\srcds and I now have SRCDS in c:\srcds\css. That's where my problem is. I've searched everywhere for something to get SRCDS to run. Yes, I've created a shortcut, which I call Run SRCDS, but it won't open. I've gone into the shortcut properties and put in the "Target" bar every possible thing you can imagine. Right now, what I have in it is "C:\srcds\css\srcds.exe -console -game tf -tickrate 33 -ip -port 27015 -maxplayers 32 +map mvm_mannworks" I tried adjusting it to the type of game I want to play [MvM] but I'm not sure that's quite how it works, because SRCDS will never open...
If there's anyone out there who's super smart and nice who'd be willing to walk me though this, step-by-step, please let me know. I'd also appreciate it if, once my server is up and running, you'd tell me how I'd install Source Mod into it.
Thanks again!
There's your problem! Right here: "-console -game tf" is wrong its the other way around like this: C:\srcds\css\srcds.exe -game tf -console +tickrate 33 +ip +hostport 27015 +maxplayers 32 +map mvm_mannworks
Ah, thanks for telling me that.
But, still won't open. I don't know if something went wrong with hldsupdatetool or what...I'm actually a bit concerned that something did. When I'd installed it and updated it and everything, the whole first part of the download it said files were "Missing" [Sorry, can't give a more detailed explanation. I can't get the screen to come up again 'cause it's all updated]. In the little Command box it was scrolling through ridiculously fast displaying the "Missing" file message [and they were missing files for TF2, I remember certain weapon names were the title but I can't remember the file type]. that where I went wrong? If so, how could I fix that? I MAY have updated files for the wrong game simply because I was following a tutorial for another game [couldn't find any for TF2]. Cstrike, I think it was. Unless you're supposed to use Cstrike for whatever reason.
I apologize if that made no sense, but, that's my problem...
[If you'd like more info, I was following this tutorial; but got stuck at the part where we open SRCDS. There was no command prompt and there still isn't one :\]
You did nothing wrong. Give me an EXACT copy and paste of your command boot. Without that, I can't determine if it's a user issue or a program issue.
It won't update again since I'm pretty sure it's all updated and I can't open the HldsUpdateTool for more than two seconds [because the Command boot just opens up, checks everything instantly then closes] but, I'll tell you what I did see to the best of my knowledge.
It would start the download and it would say "Updating Installation" and such, then it would do something like this
1:05 0.76% Missing c:\srcds\orangebox/tf\pyro_rainblower.[file type]
...Er...if my memory serves me then it showed something similar to that, then went on, downloading things normally, like this
3:56 3.56% Downloading c:\srcds\orangebox/tf\...[etc]
Looking in c:\srcds\orangebox\tf it seems that most of the folders are empty. I went to c:\srcds\orangebox\tf\models\bots and all the folders there are empty. in c:\srcds\orangebox\tf\maps I don't seem to have any MvM maps. Lots of the files in c:\srcds\orangebox\tf\models\weapons don't seem to be there either.
...Hope that shed some light on something, because I'm totally clueless.
Try adding -verify_all to your command line for the updater tool.
Earn Points, get Free Rewards with your Amazon Points!

By command boot I meant what you put in the target properties such as: -game tf -console +map mvm_coaltown etc. etc.
Ooh, okay.
Well, I'm fiddling with stuff now. I decided that I'd give on on making an MvM server, rather I'll try making a regular TF2 server.
I've got C:\SRCDS\orangebox\srcds.exe -game tf -console +tickrate 33 +ip +hostport 27015 +maxplayers 32 +map cp_gravelpit in the command boot now and the command prompt for the server will open but every time it says "Couldn't allocate any server IP port"
So, uh, what does this mean? I've got all my files sorted out now and this is the only problem I'm having.

EDIT: I just got it to open. If I have any more problems, I'll be sure to mention them!
Have you tried -port 27015 instead of -hostport 27015?
Earn Points, get Free Rewards with your Amazon Points!

It's all right, my server console is up and running now. That's what I was aiming for.
I just have one do I get into my server now? Do I have to do it via the server console?
You can try finding it through the global server list.

Or just use your external ip with the port to connect to the server through console.

Launch your TF2 game, access console and type the following below.

" connect ip:port " in console.

For example,

Earn Points, get Free Rewards with your Amazon Points!


Forum Jump:

Users browsing this thread: 1 Guest(s)