SRCDS Steam group

[Solved]Server Doesn't Update
I recall getting this error a few times before, but I don't remember how I fixed it.

About 3 hours ago, all of my servers emptied out and got the error
Your server is out of date. Please update and restart.

I've tried verifying TF2's game cache and using the HLDSUpdateTool, restarting Steam, and using -verify_all but nothing.

The command I use to update is:
J:\srcds>hldsupdatetool -command update -game tf -dir J:\srcds -verify_all

Server OS: Windows 7 Home Premium
Processor: AMD A6-3620 APU with Radeon(tm) HD Graphics 2.20 GHz
Game: Team Fortress 2
Start Up Command: J:\srcds\orangebox\srcds.exe -console -game tf +hostport 27015 +maxplayers 32 +map mvm_decoy
Admin Mods: Sourcemod
You typed this for your HLDSUpdateTool.

J:\srcds>hldsupdatetool -command update -game tf -dir J:\srcds -verify_all

Shouldn't it be this.

J:\srcds\hldsupdatetool -command update -game tf -dir J:\srcds -verify_all

You have a > instead of a \.

What kind of error are you getting for the HLDSUpdateTool? The console does not load up or it freezes in the process of updating?
Earn Points, get Free Rewards with your Amazon Points!

The > Is automatic (I type cd srcds to make it slightly easier). Does that actually affect the process?

The entire thing seems to run fine, but the server isn't being updated (or doesn't think it is..?)
So no one has any ideas? Sad

I think it has something to do with the HLDSUpdateTool not actually being updated itself. Maybe it's trying to update with an older version?

Is there a way to manually update SRCDS while not using HLDSUpdateTool?

I just stuck the entire Steam TF folder (as well as the Bin, HL2, and Platform folders) into the SRCDS Orangebox folder. It is still apparently not up to date.

Is it possible that SRCDS is just bugged out and I should try to reinstall everything? -answer

I'm not sure whether or not it was the folder, SRCDS, or maybe a folder in there messing it up, but a complete reinstall (delete entire Orangebox folder) and recreating it worked.

Forum Jump:

Users browsing this thread: 1 Guest(s)