SRCDS Steam group

Trying to play synergy LAN on dedicated, keep getting kicked every few minutes
I am hosting a dedicated server via srcds and whenever I join it (on the same machine), I get kicked after a few minutes because steam can apparently not connect to the VAC servers.

I have VAC turned off in the batch file that I run HLDS with, and I'm running my steam client in offline mode. It seems to not have the problem when I'm not in offline mode, but if I want to play in offline mode, why can't I?

I don't understand, I turned off VAC on my dedicated server, so why is it still trying to connect? Why am I getting kicked?

Is there any way to prevent this from happening while playing in offline mode? I just want to play synergy LAN with my brother.
Can you post up your startup command line and server.cfg if you have one?
Earn Points, get Free Rewards with your Amazon Points!

(08-16-2012, 10:35 AM)Ghost Assassin Wrote:  Can you post up your startup command line and server.cfg if you have one?

Yeah, definitely. I don't have a server.cfg (to my knowledge).

Edit: Here's my HLDS batch file:

"C:\Program Files (x86)\Valve\HLServer\synergy\orangebox\srcds" -console -game synergy -ip -maxplayers 4 +map d1_trainstation_03 -insecure -port 27015 +sv_lan 1

Command line upon starting HLDS with my batch file:

100.0 fps  0/ 4 on map d1_trainstation_03
Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Synergy"
Steam Content [SV]: mounted game 420 (1)
Steam Content [SV]: mounted game 380 (1)
Steam Content [SV]: mounted game 220 (1)
Unable to remove c:\program files (x86)\valve\hlserver\synergy\orangebox\synergy
maxplayers set to 4
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Steam Content [SV]: changing games for level d1_trainstation_03
Steam Content [SV]: found game hl2
Steam Content [SV]: adding unused path from ep2
Steam Content [SV]: adding unused path from ep1
CModelLoader::Map_IsValid:  No such map 'maps/metastasis_1.bsp'
CModelLoader::Map_IsValid:  No such map 'maps/metastasis_2.bsp'
CModelLoader::Map_IsValid:  No such map 'maps/metastasis_3.bsp'
CModelLoader::Map_IsValid:  No such map 'maps/metastasis_4a.bsp'
CModelLoader::Map_IsValid:  No such map 'maps/metastasis_4b.bsp'
Read 33/256 valid map names from 'maplist.txt' for vote system
Unknown command "sk_Houndeye_health"
Unknown command "sk_Houndeye_dmg_blast"
Executing dedicated server config file
NoBans:  read 0 lines from file
Error reading weapon data file for: weapon_oldmanharpoon
NPC npc_flr1_citizen3 using alternate collision! -- DISABLED
NPC citizen_PreRaid_Peeker using alternate collision! -- DISABLED
NPC npc_flr2_citizen2 using alternate collision! -- DISABLED
NPC npc_flr2_citizen3 using alternate collision! -- DISABLED
NPC npc_flr2_citizen4 using alternate collision! -- DISABLED
Failed to load Steam Service
ServiceStart: failed to start
gameserver.cpp (107) : Assertion Failed: m_unAppIdServed != k_uAppIdInvalid
Assert( Assertion Failed: m_unAppIdServed != k_uAppIdInvalid ):gameserver.cpp:10

gameserver.cpp (730) : Assertion Failed: m_CMInterface.GetLogonState() == k_ELog
exec: couldn't exec server.cfg
Adding master server
Adding master server
   VAC secure mode disabled.

Notice how it says "VAC secure mode disabled", and yet it still (apparently) tries to connect to VAC and boots me when it can't..

I'm not sure what all those errors are or if they're significant. I followed this guide to set up a dedicated Synergy server via HLDS.

Also, I've tried simply using the dedicated server tool that you can access in steam by going to tools. I've made sure to uncheck the VAC option, but it doesn't seem to have a different result (i.e. - I also get kicked after a few minutes).

And to be honest, I'd rather do make a dedicated server via the steam tool as opposed to HLDS because it would take up less HDD space.

Edit #2: After some more testing, it seems that the problem arises when I change to a Half-Life 2 campaign map, such as d1_trainstation_03. For example, if I start a dedicated server through the steam client, I can only choose from the default synergy maps which come with the synergy mod. However, once I've loaded the synergy map, I can use the command "map d1_trainstation_01" to effectively start playing the Half-Life 2 campaign.

I can hang out in the synergy maps all day long, but it seems that as soon as I switch to d1_trainstation_01, it starts a timer and a few minutes later I get kicked because it says it can't connect to VAC. Even in the console window after I change maps, it says that VAC is disabled.

Edit #3: So when you create a dedicated synergy server through the steam tools, you can only choose from the default synergy maps that come with synergy. You can't choose any of the Half-Life 2 campaign maps such as d1_trainstation_01.

So what I had been doing was simply using the command "map d1_trainstation_01" in the in-game console window to switch to the HL2 campaign, and it worked, but it would kick me out after a few minutes due to that VAC error message (how it couldn't connect to the VAC servers).

Well, I didn't even realize that there was another console available -- the one that you get when you create the dedicated server. I was using the in-game console for everything. This time, I used "map d1_trainstation_01" in the dedicated server console, and switched the map before even entering the game.

When I joined the game, I was able to play and I did not get kicked out after several minutes.

This is great, I thought. So, I alt-tabbed back out to the server console window (not using the in-game console anymore) and tried to change to another campaign map (map d1_trainstation_03). As soon as I hit "enter", it kicked me out of the game because this time it said "disconnect: server shutting down".

The thing is that the server did in fact NOT shut down. When I rejoined my server, it was on the map that I had changed it to.

So in summary, it seems that using the in-game console to change maps results in VAC errors, but using the server console to change maps will kick me from the game due to an error that says "disconnect: server shutting down".

Edit #4: I think I'm beginning to understand this behavior a little better. It seems that using the in-game client console to change maps (when I'm connected to my steam DS which is running on the same machine) is actually disconnecting me from the server! I didn't even realize this. It's like I go into single-player mode or something for a few minutes until I get a VAC error, which I'm guessing is happening because I'm supposed to be connected to the server, but I'm not anymore. When I checked the steam DS GUI after doing a client console map change, my name was no longer listed under the players list and it said I had disconnected.

So using the in-game client console to change maps seems to be a big no-no because it disconnects me from the server itself. If I was using a listen server, I'm guessing that this would probably be fine (because the in-game client console also serves as the server console (I think)), but since I'm using a dedicated server, I need to use the server console or at least use rcon to control the server console through the client console. I have an extremely rudimentary understanding of these things as you probably know, and I'm learning a lot of this for the first time.

So back to using the actual server console -- it's all great except for the fact that I get disconnected upon map changes. Apparently, this is actually normal behavior upon a map change and the clients simply get reconnected after they get disconnected, but the whole "reconnect" part does not seem to be happening for me. I have to manually reconnect to the server. Any ideas?

Forum Jump:

Users browsing this thread: 1 Guest(s)