SRCDS Steam group

[SOLVED] Error on SRCDS Startup [For Team Fortress 2]
So it's been a few months since my last server run as my port forwarding wasn't working. Today, I managed to fix the port forwarding and update the server but there's a problem that's really annoying me and if anyone can help me resolve this, I'll thank them from the bottom of my heart.

So the problem is...

Whenever I try to start the server via the command:
orangebox\srcds.exe -console -game tf +map ctf_2fort -port 27030 -maxplayers 24 -autoupdate
I get the error
The procedure entry point ?IsThreadRunning@CThread@@MAE_NXZ could not be located in the dynamic link library tier0.dll.
and after heaps of searching on the internet, I found out that nobody had the same problem as me.

I've already tried copying the .dll files from orangebox\bin to orangebox but it didn't work.

Thanks in advance.

Wow I feel so derp. I didn't see the "tier0.dll" in the orangebox\bin but I saw tier0_s.dll. Now I saw it and all I had to do was copy tier0.dll from orangebox\bin to orangebox :3

Forum Jump:

Users browsing this thread: 1 Guest(s)