SRCDS Steam group

IP Connection Issue
Copied from D-Link forums. Posted it here aswell cus i thought mabye someone could help me out here aswell Smile

Hi, i just got my D-Link DIR-857 and everything works fine except one thing. I can't connect to my server using my public IP address ( If i try to connect to my website that is connected to my public IP address through a web browser everything works fine even if i type my public IP address it works. But when i try to connect to one of my Counter-Strike: Source servers via my public IP address or via my domain it won't work. I have to use the internal IP address of my server ( to be able to connect to them. Also if i add the server to my favorites on the game or on steam it won't show up. It only shows up if i use the internal IP address. Also i can't download anything from my Counter-Strike: Source servers like a map if i don't have it cus the server sends the files from my website that i can't connect to except via a web browser. I also use a plugin called SourceBans that comes with a web interface made in php. And you connect all your servers to it so if you ban a player from one server they will get banned from all the servers that are connected to your SourceBans installation. The problem here is that the server it self that hosts the webserver with the SourceBans installation, MySQL and the Counter-Strike: Source servers can't connect to it self via my public IP address. And when i add the servers to my SourceBans installation i must use the servers internal IP address for the SourceBans installation to be able to connect to my Counter-Strike: Source servers. And that is a big problem because people often goes to my SourceBans page and clicks on the servers and then they click on connect. And then they are supposed to connect to the server but they will connect to my servers internal IP address so the connection will fail for them. As i mentioned before this is a very big problem for me so help would be very appreciated. Thx in advance Smile

Hardware Version: A1
Firmware Version: 1.01
The problem has been solved at the D-Link forums. So if anyone has the same problem then visit this site.
(07-05-2012, 03:35 AM)HolyDuFF Wrote:  The problem has been solved at the D-Link forums. So if anyone has the same problem then visit this site.

Yep. definately a port forwarding issue with virtual server settings. Good job working though it. Would you please be so kind as to edit the title of your original post and place [Resolved] in it so people know its fixed?

About Me:
I help people who at least try to help themselves. Please use the "Search" button before posting a new topic.
If you post, give us the info we need from the "READ ME FIRST" sticky at the top of each thread!

I'm here to share my experiences to help others. If I'm wrong about something, don't hold it against me, educate me.
I not perfect and try to learn from every failure, yours and mine.

Forum Jump:

Users browsing this thread: 1 Guest(s)