SRCDS Steam group

Server Not Appearing Publicly
Server OS: Ubuntu Server 32-bit
Processor: Intel Core 2 Duo 2.33 GHz
Ram: 4 GB
Game(s): TF2
Start Up Command: ./srcds_run -game tf +map cp_degrootkeep
Admin Mods: MetaMod, Mani's Admin Mod

I am currently running a TF2 server on a Ubuntu Linux PC. I have my router in DMZ mode, and the server is updated completely. I can connect to the server on LAN, but it cannot be accessed by the public ip listed in both the console, or at I have tried accessing it by both using the "connect" command in the Developer's Console and by looking it up through the "Favorite Servers" window.

Possible solutions? There is obviously no firewall on the computer. In addition, my config file has no ip specified, so that shouldn't be an issue. On startup, my server lists the correct ip address, but I have no clue why I can't connect to it.

In addition, if someone could direct me to a COMPLETE guide to building a Tf2 server, I would greatly appreciate it. I believe I have done everything correctly, however please, correct me if I'm wrong. Also, you should know: I tried to make a Tf2 server on a Windows 7 computer as well - the result was exactly the same. However, I did not copy ANY files - I re-downloaded everything and redid the configs. Please, help me with this pending issue.
You're trying to host this off your home server computer right? Well I've had friends that had the same problem as you. They would forward their ports, enable DMZ, and do what ever it took to host but they just couldn't. This had to do with their router not allowing any incoming connections for some strange reason. Once they bought a new router they could host again. This could also be a problem with your current internet service provider.
Well, at current, I have AT&T (Uverse) as my Internet Service Provider. I have the basic 2Wire router they setup for me about 2 years back.

Well, now that I know that my router may be the problem, how would I go about replacing a router for an AT&T network? This router is also connecting my home phone line and TV boxes to the network, and they completely rely on each other (as anyone with AT&T Uverse would know - AT&T forces you to use their services like this).

In the past, I considered running a router out of one of the ethernet ports on my 2Wire router, and then set the 2Wire router in DMZ mode, however I was unsure that this would work, considering it doesn't seem to work when I open a single range of ports and forward them.

In addition, I think that all who are reading this should know: I have successfully hosted a Minecraft (Mojang) server on this network, and on the exact same computer. I opened the ports just the same and had them forwarded. Something like 50 people at a time could access the server from across the country.

So, any solution to the problem are welcome. I would prefer one that involves me modifying the current arrangement, however if a new router is necessary, please don't hesitate to say so.
Wait you're trying to host a server off of your modem? If so you need a router connected to your modem in order to enable hosting. Toungue
(04-15-2012, 12:11 PM)koz Wrote:  Wait you're trying to host a server off of your modem? If so you need a router connected to your modem in order to enable hosting. Toungue

Sorry - typo. I fixed it - but, no, I am trying to host off a router. Thanks for catching that! Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)