SRCDS Steam group

HLDS Linux Download Perpetually Stalls
Hey everyone! I am having a great deal of trouble trying to install the TF2 server to my Ubuntu server, with the following specs:

Ubuntu Server 10.10 32-bit
Athlon64 Single Core at 1.2 Ghz
768 MB RAM
100 GB Main HDD, 250 GB Slave

I have tried the instructions listed on the Steam TF2 wiki for Linux CLI install, but I cannot manage to complete the download. I first created a new user, as suggested, and then used the command

wget && chmod +x hldsupdatetool.bin

to download the hlds update tool. I ran it as suggested, and after several runs it fully updated the steam installation, creating the requisite steam binary and folders. I then attempted to run

./steam -command update -game tf -dir server/ -retry -verify_all

as suggested by looking at the man pages, but in every case it will be absurdly slow and will never finish the download. This is perhaps my eight attempt at this, and I am going slightly mad (with apologies to Queen). At one point it took about two days and made it to 60%, but locked up after that. Since then I have not been able to make it go past 1-5%, even after several days. I am on a college campus, and our internet is quite snappy (I can download the full TF2 for windows in only a few hours) and we have 200+ megabits of bandwidth campus wide, along with download speeds of at least 1MB and usually around 10. It is my humble opinion that speed is not an issue, but I cannot for the life of me figure out why the download is failing. I tried deleting everything and starting over, deleting the InstallSomething.blob file and starting over (multiple times), but nothing has yielded any success. I have also not had any problems with internet connectivity with this machine, just a thought. If you guys have any suggestions I would really appreciate them, thanks!

Forum Jump:

Users browsing this thread: 1 Guest(s)