SRCDS Steam group

L4D Update Help - Segfault
Hey there,

Just loaded on the new update for L4D and am having no joy starting it up - heres what I am running.

Cmd Line

srcds_run -game left4dead +ip x.x.x.x +hostport xxxxx +map l4d_vs_hospital01_apartment +sv_lan 0


Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.
Running a benchmark to measure system clock frequency...
Finished RDTSC test. To prevent the startup delay from this benchmark, set the environment variable RDTSC_FREQUENCY to 3000.000000 on this system. This value is dependent upon the CPU clock speed and architecture and should be determined separately for each server. The use of this mechanism for timing can be disabled by setting RDTSC_FREQUENCY to 'disabled'.
#Console initialized.
#Game.dll loaded for "L4D - Normal"
Server is hibernating
ConVarRef test_progression_loop doesn't point to an existing ConVar
Game supporting (2) split screen players
maxplayers set to 14
Unknown command "r_decal_cullsize"
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP x.x.x.x, mode MP, dedicated Yes, ports 27015 SV / 27006 CL
---- Host_NewGame ----
Host_NewGame on map l4d_vs_hospital01_apartment
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
Segmentation fault
Add "-debug" to the /home/orix/srcds/l4d/srcds_run command line to generate a debug.log to help with solving this problem
Thu Jan 15 16:07:58 EST 2009: Server restart in 10 seconds
Thu Jan 15 16:07:59 EST 2009: Server Quit

I have tried adding -debug to the cmd line and got this:

CRASH: Thu Jan 15 16:43:34 EST 2009
Start Line: ./srcds_i486 -game left4dead +ip x.x.x.x +hostport 27015 +map l4d_vs_hospital01_apartment +sv_lan 0 -debug -fork  +map l4d_hospital01_apartment
End of Source crash report

Can anyone let me know how to get the debug to work, or what could be the problem? I have tried a fresh download of all the install files. My server.cfg is as follows:


// Server Name
hostname L4D"

// Rcon Cvars
rcon_password "xxx" //Set's remote control password

// Server Password
//sv_password "" // Password protects server

// Server Cvars

mp_disable_autokick 1 //Prevents a userid from being auto-kicked
sv_clearhinthistory 0 //Clear memory of server side hints displayed to the player.
sv_consistency 1 //Whether the server enforces file consistency for critical files
sv_contact "xxx" //Contact email for server sysop
sv_pausable 0 //Is the server pausable.
sv_allow_wait_command 0

// Lan or internet play, Server region cvars
//sv_lan 0 //Server is a lan server ( no heartbeat, no authentication, no non-class C addresses )
sv_region 5 // Region Codes: 0 - US East coast, 1 - US West coast, 2 - South America, 3 - Europe, 4 - Asia, 5 - Australia, 6 - Middle East, 7 - Africa, 255 - world

// HTTP Redirect
//sv_downloadurl ""

// Server Logging
//sv_log_onefile 0 //Log server information to only one file.
//sv_logbans 1 //Log server bans in the server logs.
//sv_logecho 0 //Echo log information to the console.
//sv_logfile 1 //Log server information in the log file.
//sv_logflush 0 //Flush the log file to disk on each write (slow).
//sv_logsdir "logs" //Folder in the game directory where server logs will be stored.

//Server Rates

//sv_minrate 5000
//sv_maxrate 30000
//sv_mincmdrate 20
//sv_maxcmdrate 100

//sv_steamgroup_exclusive 0
//sv_steamgroup 603394
//sv_tags ""

//sv_search_key ""

Any ideas? is anyone else running Ubuntu having problems since the patch??

**UPDATE im now getting the following line after the seg fault - not sure if this helps or not

Executing dedicated server config file
Segmentation fault (core dumped)
cat: No such file or directory
Never mind - I fixed it!

The vm that I was running on didnt have enough memory allocated to it Wink

Thanks for your time

Forum Jump:

Users browsing this thread: 1 Guest(s)