SRCDS Steam group

server.cfg error?
my server.cfg text, which has the proper .cfg filetype association and is located in my /srcds/l4d/cfg/ folder
hostname "Ace King's Test"
rcon_password "passhere"
sv_search_key "keyhere"
sv_allow_lobby_connect_only 0
sv_region 0
sv_lan 0
mp_disable_autokick 1
sv_cheats 0

the linux terminal dump
[root@ryanp4 l4d]# ./srcds_run -console maxplayers 8 -game left4dead +sv_lan 0 -                                                                                                 nomaster +map l4d_vs_hospital01_apartment +ip -port 27015
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.
Running a benchmark to measure system clock frequency...
Finished RDTSC test. To prevent the startup delay from this benchmark, set the environment variable RDTSC_FREQUENCY to 2799.000000 on this system. This value is dependent upon the CPU clock speed and architecture and should be determined separately for each server. The use of this mechanism for timing can be disabled by setting RDTSC_FREQUENCY to 'disabled'.
#Console initialized.
#Game.dll loaded for "L4D - Normal"
Server is hibernating
ConVarRef test_progression_loop doesn't point to an existing ConVar
Game supporting (2) split screen players
maxplayers set to 14
Unknown command "r_decal_cullsize"
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
---- Host_NewGame ----
Host_NewGame on map l4d_vs_hospital01_apartment
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
Commentary: Could not find commentary data file 'maps/l4d_vs_hospital01_apartment_commentary.txt'.
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
exec: couldn't exec server.cfg
Master server communication disabled.
Connection to Steam servers successful.
   VAC secure mode is activated.

What concerns me (as a relative novice in linux and hosting my own server) is that it can't exec my server.cfg and that it doesn't continue on to the master servers and fully launch. I cannot connect to it in l4d's console. This is behind a router, but all ports are forwarded to the static local ip address of that I gave its specific mac address now that it is set on dmz. I'm fairly confident that the dmz is functioning right as I couldn't even update it and get this far until I got that right (I think...), leading to this issue.
Your .cfg file is located in the wrong directory. Just try moving it around and it should eventually work! Make sure the .cfg file isn't protected in any weird way, too Smile !
Thought it was /srcds/l4d/cfg/ but it must be in /srcds/l4d/left4dead/cfg, indeed thanks. Of course it still doesn't work but I've gotta mess with things some more before I consider asking for additional help
Give several folders a try, yes!
see if this helps

put your config file in the correct path
< /home/user_name/l4d/left4dead/cfg >

// Left 4 Dead Server.cfg File
hostname "Left 4 Dead -"

// Rcon Cvars
rcon_password ""

// Steam Group Settings
//sv_search_key ""
//sv_steamgroup "11xx"
//sv_steamgroup_exclusive "1" //to make it exclusive and private

// Server Cvars
sv_allow_lobby_connect_only "0"
sv_allow_color_correction "0"
sv_allow_wait_command "0"
sv_alltalk "0"
sv_alternateticks "0"
sv_cheats "0"
sv_clearhinthistory "0"
sv_consistency "1"
sv_contact ""
sv_downloadurl ""

// Lan or internet play, Server region cvars
sv_lan "0"
sv_region "1"
z_difficulty "hard"     //this is the difficulty setting

// Server Logging
sv_log_onefile "0"
sv_logbans "1"
sv_logecho "0"
sv_logfile "1"
sv_logflush "0"
sv_logsdir "logs"

//Server Rates
sv_maxcmdrate "101"
sv_mincmdrate "101"
sv_maxupdaterate "101"
sv_minupdaterate "101"
sv_maxrate "25000"
sv_minrate "5000"
sv_unlag "1"
sv_maxunlag ".5"

//Fix to get your server onto the master lists
setmaster add
setmaster add

also make sure you do not have any ports block if you can not see this online or in the game browser

Forum Jump:

Users browsing this thread: 1 Guest(s)