SRCDS Steam group

CentOS Server problems
Hey guys,

I've got some serious problems with my Centos-root.
I installed srcds (css) and hlds on my server. But when I start srcds it says always:

appdatacache.cpp (311) : Assertion failed: "Implement me!"

and sometimes something like threadtools.cpp...

The hlds(1.6) has also some issues:
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.

What's this? The rest of my system works great. How can I fix this?
Re-installing doesn't help.
Nobody wants to help?
After doing some Googling, it looks like it could be a problem with your GLIBC. Upgrade GLIBC using your favorite package manager, and try again.
I tried yum upgrade but it's still the same problem.
Actually you can ignore both messages the one for the css server is a note for the developer to add in code hints the Insert me! the second is a minor issue with update but it will not effect anything. You should be fine.
*Windows lack of output*
You: Hey, I want to run this program!
Windows: Ok.. It crashed... Now what? Give up?
*linux output helpful?*
You: ./My_program
Linux:...Failed!...oo kitties!
And I can really ignore the errors?
Do you get the same error-messages?

However, I tested the server for a few days and it worked fine, so thank you!
That's a common mistake people do, you take error messages way too seriously. If the server works fine, then there is usually no problem with bits and pieces of random errors here and there.

Forum Jump:

Users browsing this thread: 1 Guest(s)