SRCDS Steam group

Low FPS on L4D Server *NEW ISSUE*
I'm having trouble with my L4D dedicated server, I'll try and post as much info as possible so bare with me Smile

I started off running it on a Pentium III coppermine with 320 MB of RAM and got about 20FPS, I didn't expect much better. So I moved it over to a Pentium 4 Northwood @ 2.4 GHz with 512 MB of RAM, now I'm getting 27FPS....

Being a server the kernel (2.6.18) was set with 100Hz timer frequency with no preemption. After reading around this site I found that 1000Hz with preemption was better, and recompiled a new 2.6.27 kernel. Now I'm getting 30FPS....

I tried all the recommendations here and nothing helped.

Most of my users are experiencing 200+ ping, traceroute to their IP reveals ~70ms latency to the last router hop. My connection is not optimal, but I am able to host co-op from my desktop with no lag over the same connection.

System specs: P4 Northwood @ 2.4 GHz w/ 400MHz FSB (huge fsb bottleneck), 512MB RAM, 40MB ATA hard drive, Intel desktop mobo (not sure on chipset)

OS: Debian Linux on 2.6.27 kernel, gcc 4.3.2 i486, glibc 2.7

I've attached server init scripts and current cfg (for some reason it wouldn't let me attach them without adding .txt extension)

Options from init script

Quote:# Server options
TITLE='Left 4 Dead' # Full title of game type
NAME='l4d' # Server handle for the screen session
DAEMON='srcds_run' # The server daemon
STEAM='/etc/steam/l4d' # location of steam instalation

# Game options
IP='' # IP of server
MAP='l4d_hospital01_apartment' # Initial map to start
GAME='left4dead' # Game type
FORK='1' # # of server instances
CLIENT='27005' # Client Ports
HOST='27015' # Host Ports
MATCH='27025' # Match Ports
STEAMPORT='27690' # Sytem Ports

# Server options string
OPTS="+clientport $CLIENT+## \
+hostport $HOST+## \
+matchmackingport $MATCH+## \
+systemlinkport $SYSTEM+## \
+exec server_cfg##.cfg \
+map $MAP \
+ip $IP \
-tickrate 66 \
-steamport STEAMPORT+## \
-fork $FORK \
-netconport 90## \
-netconpassword ******** \
-game $GAME \
-autoupdate \
-pidfile $STEAM/$GAME/$"

Am I missing something or should it really be running this slow? The server plays fine for the most part but the zombies lag horribly. Thanks for any help in advance!

Attached Files
.txt   hlds.txt (Size: 2.83 KB / Downloads: 11)
.txt   server_cfg01.cfg.txt (Size: 896 bytes / Downloads: 14)
[Image: b_350x20_C692108-381007-FFFFFF-000000.png]
l4d is made to not go over 30 fps
helixo Wrote:l4d is made to not go over 30 fps


Big Grin

Can't believe I couldn't turn that up after hours off googling....

So, any reason none of the bandwidth CVARS work anymore with L4D? sv_maxupdatrate for example? Seems like I can't control bandwidth optimally for my less that perfect connection (512kb/s up).

Thanks for the fast response btw!
[Image: b_350x20_C692108-381007-FFFFFF-000000.png]
On server.cfg execution i get

Quote:Unknown command "sv_voicecodec"
Unknown command "sv_voicequality"
Unknown command "mp_chattime"
Unknown command "mp_forcecamera"
Unknown command "decalfrequency"
Unknown command "sv_allowupload"
Unknown command "sv_allowdownload"
Unknown command "sv_maxupdaterate"
Unknown command "sv_minupdaterate"
Unknown command "sv_instancebaselines"
Unknown command "sv_maxunlag"
Unknown command "sv_unlag"

All of which are in the server.cfg, some more important than others. How am I supposed to control bandwidth without these?
[Image: b_350x20_C692108-381007-FFFFFF-000000.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)