SRCDS Steam group


l4d, unable to connect to server when sv_lan 0
#1
When sv_lan 1 is set, I can see my server when I load the game, but if I try to join it, it fails after 10 tries. I can still get connected, but I have to open the console and run connect 192.168.15.5. I cannot just join it via the serverbrowser.

If I have sv_lan 0, I cannot join at all, using the connect command to my NAT IP or to my routers IP, or trying to load it regularly via the serverbrowser. However I see people joining my server with no problem, it just appears to be unjoinable inside my local network.

My l4d server has 192.168.15.5 staticly bound and has the following ports forwarded to it.
UDP 1200
UDP 27000 - 27020
TCP 27015
TCP 27030 - 27039


Here is my server.cfg, not sure if it'll help.
Code:
// server name
hostname "The Unfeed Zombie"

// server cvars
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_voiceenable 1
mp_disable_autokick 1

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 20000
sv_maxcmdrate 100

// server logging
log off
sv_logbans 1
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 0

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

Here is the output from starting the server.
Code:
tynin@ubuntu:/srcds_l/l4d$ ./srcds_run -console -game left4dead -autoupdate -tickrate 100 +ip 192.168.15.5 -port 27015
Auto detecting CPU
Using AMD Optimised binary.
Server will auto-restart if there is a crash.
Could not locate steam binary:./steam, ignoring.
#
#Console initialized.
#Game.dll loaded for "L4D - Normal"
Server is hibernating
ConVarRef test_progression_loop doesn't point to an existing ConVar
Game supporting (2) split screen players
maxplayers set to 14
Unknown command "r_decal_cullsize"
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP 192.168.15.5, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
---- Host_NewGame ----
Host_NewGame on map l4d_hospital01_apartment
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
Commentary: Loading commentary data from maps/l4d_hospital01_apartment_commentary.txt.
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
Connection to Steam servers successful.
   VAC secure mode is activated.

I'm running ubuntu 8.10 server.
uname -a
Linux ubuntu 2.6.27-7-server #1 SMP Fri Oct 24 07:37:55 UTC 2008 i686 GNU/Linux


Any suggestions? Thanks in advance, you all have a great community forum going on here.

edit: As a distant 2nd question, does anyone know what is causing the handful of errors I posted from my startup. It doesn't seem to cause any problems as I had a LAN game going for 4 hours this morning with 3 people playing locally on this server. Still, I don't like to see errors I cannot account for. Specifically the following lines:

- Could not locate steam binary:./steam, ignoring. (Fixed this one, thanks injate! http://forums.srcds.com/viewtopic/8844)
- Unknown command "r_decal_cullsize"
- Unknown command "mat_bloom_scalefactor_scalar"
- ConVarRef room_type doesn't point to an existing ConVar
- [S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
Reply
#2
add "sv_allow_lobby_connect_only 0" to your server.cfg (without the quotes Smile)
and try that.

Bully.
Reply
#3
djbully Wrote:add "sv_allow_lobby_connect_only 0" to your server.cfg (without the quotes Smile)
and try that.

Bully.

This kind of worked, but not really... I have sv_lan 0 and added that command sv_allow_lobby_connect_only 0 to my cfg. If I start the server and jump in right away (before anyone on the internet finds my server and joins it) I can log in (but then no one else from the internet ever joins the server).

If anyone else on the internet joins my server before I can join, I get the disconnected after 10 tries.

Is it possible to have people connect via the LAN and the Internet at the same time? Or is it one or the other?

Thanks for the help!
Reply
#4
Looks like it might be a known issue. Hopefully Valve will save the day soon and my server will automagically work.

edit: fixed the broken url (sorry about that)
http://forums.steampowered.com/forums/showthread.php?t=750889
http://forums.steampowered.com/forums/showthread.php?t=750788
Reply
#5
I've persistenly had issues with server visibility inside my LAN. The one true solution that I've found is asking your server to register with DHCP on your router or gateway. I can accomodate this on my home network, althought I understand if it's not possible on yours.
I've also recently been suffering from inconsistent behaviour with toggling sv_lan, you've probably noticed the strange error of "[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient.dll" which shouldn't have any functional place on a Linux machine, but this error was snarling up my map changes for a while until I disabled sv_lan. I reckon this is a fairly significant bug for which we can only wait on Valve to fix.
DaRab.
Desktop:
Core2Duo E6750 @ 3.04Ghz - 2GiB DDR2 @ 800Mhz - Asus P5K Premium WiFi mobo - Hiper 530W PSU & Osiris Case - Sapphire ATi HD4870 - Creative X-Fi Xtreme Audio - Win XP Pro 32bit

Server:
Pentium 4 @ 3Ghz - 1GiB DDR2 @ 800Mhz - Asus PM5T mobo - Asus RS120-E3 1U Rackmount case - 500GB Hardware RAID0 array - Ubuntu 9.04 Server Edition - Massive Genitals.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)