SRCDS Steam group

L4D glibc options?
To start with I'm not all that familar with linux anyway here we go.

I'm trying to run a left 4 dead demo server on Debian Etch, however getting the following message:

Quote:Failed to open bin/ (/lib/tls/i686/cmov/ version `GLIBC_2.4' not found (required by bin/

From what I've been able to find out Etch only supports up to 2.3 glibc and I would need to upgrade to Lenny to use 2.4 or later ?

Is this the only option I have ?, on the same box I'm also running a COD4 server and occasionally a CSS server which are running perfectly and I don't really want to risk breaking them with any updates to glibc (which I've read is highly likely).
I'm having the same problem with a centos 4.5 server. Basically I can't upgrade it to 5.2, I have no physical access or way to have the host company do it (don't ask).

I've been looking into if it's possible to upgrade the glibc in centos4.5 but they say it's dangerous and can make the system unstable. But so can migrating a system from 4.5 to 5 with yum updates...but that's pretty much my only option at this point if I want to run left4dead on this server. So it's probably the same with debian, you just need to upgrade the OS.

the server I'm talking about here isn't the same I just posted about having a segmentation fault on.
I had the same problem and tried several things .
But upgrading to lenny was the thing that worked.

You can do this simple by going to "/etc/apt/sources.list" open and edit it by changing all words "etch" to "lenny".

now run "sudo apt-get update"
then run "sudo apt-get dist-upgrade"

Your server will be the same after this with the same users etc.

Good luck
Not sure what's out there for centos 4.x

But do a: yum list | grep glibc
Game Server Administration Services
Linux & Windows performance specialist.
will l4d work on a centos 5.2? how do i upgrade that file if needed without breaking the shell or other games?

[root]# yum list | grep glibc
glibc.i686 2.5-24.el5_2.2 installed
glibc-common.i386 2.5-24.el5_2.2 installed
glibc-devel.i386 2.5-24.el5_2.2 installed
glibc-headers.i386 2.5-24.el5_2.2 installed
compat-glibc.i386 1:2.3.4-2.26 base
compat-glibc-headers.i386 1:2.3.4-2.26 base
glibc.i386 2.5-24.el5_2.2 updates
glibc-utils.i386 2.5-24.el5_2.2 updates

Forum Jump:

Users browsing this thread: 1 Guest(s)