SRCDS Steam group

srcds_run segmentation fault, only for tf2?
Command line:
./srcds_run -game tf +maxplayers 16 +map pl_goldrush -ip +rcon_password "*****" -port 27015 -secure -console +sv_lan 0 +hostname "Lime test" -debug

CRASH: Mon Nov  3 16:57:36 CET 2008
Start Line: ./srcds_i686 -game tf +maxplayers 16 +map pl_goldrush -ip +rcon_password ****** -port 27015 -secure -console +sv_lan 0 +hostname Lime test -debug
End of Source crash report

I'm running Fedora on it. I don't quite remember which one since I had it a really long time. Have to be 8 or something.

GCC Version:
gcc (GCC) 4.1.2 20070925 (Red Hat 4.1.2-33)

GlibC version:
ldd (GNU libc) 2.7

Kernel version.

Hardware I'm using:
2GB of ECC ram, a Intel Dual Core @ 3.22GHZ, 2x 50GB Diskspace in raid. (Not much, but it works. Wink )

The problem:
The problem is, if I run the srcds_run with -game tf as a variable, it throws a segmentation fault back at me. It works fine with all other SRCDS games, and I used to be able to run one back in the old days. I also tried to run it with wine, just the srcds.exe but once a player connects and stay there for 2 minutes the server crashes without anything to notice? It just freezes, no errors, not even in the logs. I also tried with debug, nothing. Tried reinstalling TF2 too, also tried deleting the srcds_run... I run a CSS server on it, and there's no problems at all.

Any help appreciated!
Do reinstall in clean directory.

HTH Toungue

Forum Jump:

Users browsing this thread: 1 Guest(s)