SRCDS Steam group

SRCDS Lockup!!! HELP!!!
Hello all, I get this output in console, and will not go past this point. This happens randomly, everytime I start the server, or a map change occurs.

Auto detecting CPU
Using AMD Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 32
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
appdatacache.cpp (311) : Assertion Failed: !"Implement me"
couldn't exec server.cfg

Then after about 2-5 minutes, it displays this:
Adding master server
Adding master server
Connection to Steam servers successful.
   VAC secure mode is activated.

A2C_PRINT from :
No challenge for your address.

This is on a fresh install of a CSS Server, with no mods on it or anything. I run this on a Ubuntu 8.10 Desktop i386 Edition, and I have a AMD processor in it (Athelon XP 2600+).

PLZ HELP! Me and my friends would really like to play a nice game without a lockp happening Smile .
Mine too. And my friends cann't find the server. How to solve this prob?
Are you running though a VNC window?

I just did Screen over SSH, and it seems to solve this problem... Although I only did about 10 trys (all worked)..

Maybe I solved the problem, give it a try.

EDIT: no, ssh didnt solve it... However.

I put in the command line -nomaster and -insecure.. and it hangs at a different point.
It hangs after the Master Server communication disabled message comes up, which after that only comes the "connection to steam servers successful"... So what could cause that?

BTW with the friends, have you opened up all ports to let them though? and have you binded to the right ip address?
I believe it is due to this:

Network: IP


Try adding -ip "your external ip" to your startup command line.
what are you using to start your server,

./srcd_run ....
I run a shell script called from ~/servers/css, which contains:

./srcds_run -game cstrike +map de_dust2 +maxplayers 32 -ip -debug -nomaster -insecure

The nomaster and insecure switch was not originally apart of the command.

I'm behind a router also, so wouldn't it make sense to use my internal ip?

Also reverted back to Ubuntu 8.04 LTS, still doesn't fix it
what does your debug file say?
Doesn't say anything unfortunately, as it doesn't crash, it just hangs then after a while unfreezes itself.

So there is not debug.log file generated.
*sigh* Looks like I have no choice but to go back to windows server 2k3...

Linux just doesnt get along with me...

Oh well.

Forum Jump:

Users browsing this thread: 1 Guest(s)