SRCDS Steam group

hldsupdatetool.bin won't execute
Here's the story:
I install the latest Ubuntu Server Edition (8.10), for the amd64 processors (I run a Core 2 Duo).
I recompile the linux kernel (for the whole 1000fps deal).
I download hldsupdatetool.bin, copy it to a srcds folder;
joe@ubuntu:~/srcds1$ chmod +x hldsupdatetool.bin
joe@ubuntu:~/srcds1$ ./hldsupdatetool.bin
-bash: ./hldsupdatetool.bin: No such file or directory
Now, there's no error when I do chmod, and the color for the file changes from plain grey to a bright green when I check through ls.
Am I doing something stupid? I have installed ncompress (wasn't installed by default), and there's no difference.

If I can't get this fixed by Wednesday (day before L4D demo) I'm gonna have to just revert to vanilla Ubuntu 8.10.
Hmm.. why did you install AMD64 optimized version if you have Core 2 Duo? AMD's got X2 and Intel's got C2D.

Anyways, if it isn't that, then maybe it's missing 32 bit compatibility libraries.

Did you try to run it before you reinstalled kernel?
AMD renamed x86_64 to AMD64. It's just 64bit, the processor architecture is the same, afaik.

And no, I didn't try setting up srcds before I reinstalled the kernel, because I wanted to have a clean install of the new kernel before I did everything else.
..Might've been too soon to do, but I'm setting up CentOS 5 right now..
If you're running for 1000 FPS, then read this:

Ubuntu Server edition does 1000 FPS without kernel re-compile.
Okay, I reinstalled ubuntu server edition-- did the linux-rt thing instead of recompiling the kernel.
Still won't execute. Same problem.

I've been searching around, and I came across this:
I'm not sure what to think about it.

EDIT: This is really weird; I tried installing 8.04.1 instead of 8.10 (I'd gotten an install working a long time ago), but it has the same problem.

Forum Jump:

Users browsing this thread: 1 Guest(s)