SRCDS Steam group

HELP! Running debian
HLDS installation up to date

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 12
RCON Server bind failed (Cannot assign requested address)
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
appdatacache.cpp (311) : Assertion Failed: !"Implement me"
couldn't exec banned_user.cfg
couldn't exec banned_ip.cfg
Adding master server
Adding master server
Connection to Steam servers successful.
VAC secure mode is activated.

ok i dont know what happened this is pretty much my first time running a linux server.

Can not connect to server i get "Error verifying steam id ticket" or people just can not connect to it at all. It appears in the favs list but not in the net list.

Please respond asap

./srcds_run -game cstrike +map de_dust2 +maxplayers 12 -TICKRATE 66 -autoupdate -port 27015
Add "-ip" as startup parameter to get RCON to work.
yes but this still doesnt help the error verifying steam id ticket
tried deleting clientregistry.blob on the client?
"the box said 'requires windows xp or better'. so i installed linux"
Linux Ubuntu 9.04 Server 2.6.30-vanilla #1 SMP PREEMPT x86_64
yes nothing happened also,

got another error when using the -ip command,

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 12
WARNING: NNET_OpenSocket: bind: Cannot assign requested address
Couldn't allocate dedicated server UDP port
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Sat Oct 11 03:56:27 NZDT 2008: Server restart in 10 seconds
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation

PLease help me!
Is the box connected to the internet ?
Behind a router? If so fill in the LAN-ip of the server as startup item and open the following ports:

UDP 1200 (Friends Network)
UDP 27000 to 27015 (Gameport)
UDP 27020
TCP 27030 to 27039
TCP 27015 (SRCDS Rcon port)
I am having the exact same problem running debian-amd64. I have tried everything i can think of for now (even setting up a chrooted debian 32 sid installation) without any luck. I have no firewall at all and the server is directly connected to the internet (rootserver). I would be very thankfull if anyone can give me a hint, for now I am lost.
Try assigning your "local internal" ip instead. What happens?
I don't know exactly what you mean, my local internal ip is the internet ip, unless you are talking about localhost, but if I set to that no one can reach the server.
he means if you are behind a router doing nat -ip needs to be the ip on your nic, not the public ip your router is getting.
I don't know if you are familiar with rootserver (here in Germany every rented server in a serverfarm is called that way), but such a server has no router with NAT connected to it. Every packet is routed directly to the server. I even checked if there is a UDP flood protection somewhere in between but i could bombard my server with ~140MB of UDP packets and every single packet came through (I tested port 27005 since I suspected client packets being filtered).

Edit: So i figured since everything i could think of seems to be alright I give it another shot today and voilà! I didn't change a thing, but I can connect now without problems (others have yet to try, but yesterday everyone got kicked because of "Error verifying steam id ticket"). Looks like this time valve had trouble, not me Smile
I know this might be a stupid question, but have you looked at your interfaces file?

Forum Jump:

Users browsing this thread: 1 Guest(s)