SRCDS Steam group

srcds_i686 not work
if i run with:
./srcds_run -binary ./srcds_i686 -game cstrike +maxplayers 16 -port 27035 -debug
i always got the following error message:

- Enabling debug mode
- Auto-restarting the server on crash
- ./srcds_run: line 426: 16759 Illegal instruction (core dumped) - - - $HL_CMD
- warning: current_sos: Can't read pathname for load map: Input/output - - error

- email debug.log to
- Fri May 13 02:45:44 CEST 2005: Server restart in 10 seconds
- Fri May 13 02:45:45 CEST 2005: Server Quit

this is the log:

CRASH: Fri May 13 02:45:44 CEST 2005
Start Line: ./srcds_i686 -binary ./srcds_i686 -game cstrike +maxplayers 16 -port 27035 -debug
Using host libthread_db library "/lib/".
Core was generated by `./srcds_i686 -binary ./srcds_i686 -game cstrike +maxplayers 16 -port 27035 -deb'.
Program terminated with signal 4, Illegal instruction.
#0 0xb7e54a50 in MathLib_Init () from bin/
#0 0xb7e54a50 in MathLib_Init () from bin/
#1 0xb7e4d43f in main () from bin/
#2 0x0804903d in main ()
No symbol table info available.
From To Syms Read Shared Object Library
0xb7fc4450 0xb7fdda30 Yes /lib/
0xb7fbcbc0 0xb7fbd990 Yes /lib/
0xb7ea4270 0xb7f94d14 Yes /lib/
0xb7fe97b0 0xb7ffb673 Yes /lib/
0xb7e4c5b0 0xb7e754b0 Yes bin/
0xb7e15390 0xb7e29550 Yes bin/
0xb7df9ff0 0xb7e037a0 Yes bin/
Stack level 0, frame at 0xbfffda00:
eip = 0xb7e54a50 in MathLib_Init(float, float, float, int, bool, bool, bool, bool);
saved eip 0xb7e4d43f
called by frame at 0xbfffda50
Arglist at 0xbfffd9d0, args:
Locals at 0xbfffd9d0, Previous frame's sp is 0xbfffda00
Saved registers:
ebx at 0xbfffd9f8, eip at 0xbfffd9fc
End of Source crash report

only the i486 binary works...

i use gentoo 2.6 glibc-
apparently 686 was compiled with an instruction set that your cpu does not support.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
thank you for answering.
a standard pIII is not supported?

here my cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 7
model name : Pentium III (Katmai)
stepping : 3
cpu MHz : 597.436
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips : 1179.64


Forum Jump:

Users browsing this thread: 1 Guest(s)