SRCDS Steam group

Could not establish connection to Steam servers
Okay, this is really starting to irritate me.

First off, I own my own server hardware which is in a colocation facility. No firewalls, no routers in the way. It's right on the Internet.

I first downloaded and installed srcds yesterday. I got in installed and it was working fine all day long. Everything is cool. I went and downloaded Mani and got that installed. Everything worked fine. I made a few changes in some of the configs and then I started getting a couple error messages during startup:

steam@traffic srcds $ ./srcds_run -console -game cstrike +map de_dust -maxplayers 16 -autoupdate
Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 31

Checking/Installing 'Base Source Shared Models' version 3

Checking/Installing 'Base Source Shared Sounds' version 3

Checking/Installing 'Base Source Shared Materials' version 6

Checking/Installing 'Linux Source HLDS' version 36

HLDS installation up to date

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game .dll loaded for "Counter-Strike: Source"
maxplayers set to 16
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Adding master server
Adding master server
Could not establish connection to Steam servers.

The proxy error and the connection error are my problems. Now, the server runs just fine. But because it doesn't connect to Steam, my server never gets listed in the Steam server list. Extremely aggravating.

So, I turn off Mani and change some stuff back to defaults. I still get the error. Then I say screw this and just delete everything and startover. I even go so far as to redownload all the files.

It's a brand new fresh install now. I still get those two errors. I've made sure that I have sv_lan 0 and sv_region 1 set in my server.cfg.

Why doesn't it want to connect to Steam?

Here are my specfic versions:
Gentoo Linux

gcc --version
gcc (GCC) 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)

ldd --version
ldd (GNU libc) 2.3.4

uname -a
Linux traffic 2.4.26-gentoo-r9 #6 Tue Sep 28 20:45:11 MST 2004 i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux

AthlonXP 2600+ w/ 1 gig ram, pair of 200 gig hard drives

Thanks you guys. I've seen other people describe this problem too. Hopefully, we can fix it.

Can you ping the two steam servers? Gaming Servers
Licensed Ventrilo Host - AA Honor Provider - Great Service & Prices
I can ping seems to be filtering ICMP traffic, but I assume it's accessible.
Would you guys mind making sure you can get to the server as it is.

I can connect just fine, but I want to make sure somebody else can too.
Yeah, its accessable, i think that just has to do with VAC2
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.

Forum Jump:

Users browsing this thread: 1 Guest(s)