SRCDS Steam group

SOLVED: Cannot connect to Steam Master Server
Hi there,

I am trying to run a CSS server for my clan, but it isn't connecting to the Steam master servers. All the required ports are opened, and I'm running this from a dedicated server, so there isn't running behind a router.

The server is running CentOS 5, has 1GB of ram and uses a low end C2D.

[root@swatmajor1hq css]# ./srcds_run -console -game cstrike +map de_dust +port 27015 +ip +maxplayers 16 -debug
Auto detecting CPU
Using SSE2 Optimised binary.
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Unknown command "port"
maxplayers set to 16
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
appdatacache.cpp (311) : Assertion Failed: !"Implement me"
Game will not start until both teams have players.
exec banned_user.cfg: file size larger than 20MB.
exec banned_ip.cfg: file size larger than 20MB.
Adding master server
Adding master server
Game will not start until both teams have players.
Dropped [SW1] BOT Grant from server (Kicked by Console)
Could not establish connection to Steam servers.

EDIT: This problem is occurring for my TF2 server as well.

Any help would be greatly appreciated.

EDIT: I apologise for bumping this.

UPDATE: The problem is solved. It turns out that a switch that was used my my server provider wasn't sending the packets back to me.
This is a bump, sorry if this is against the rules
Do you have NAT / port forwarding?

Do you see your server on Steam server list? Does it matter that it can't connect to Steam master server?
Thats the thing, I can't see it online. And I have disabled iptables, so there shouldn't be any probs there.
not sure if this would change anything but you should try taking out the port command and see if that helps
Be absolutely sure you don't have firewall enabled.

You can check firewall blocks by "iptables -L -v -n". The output should be like this. All chains are empty:

iptables -L -v -n
Chain INPUT (policy ACCEPT 3854K packets, 389M bytes)
pkts bytes target     prot opt in     out     source               destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 3957K packets, 301M bytes)
pkts bytes target     prot opt in     out     source               destination

If your firewall is like this, then remove the -debug flag. You don't need it for any reason, but it may disable Steam connections or something like that.

Also make sure that you aren't behind a NAT.
This is the output I get from the iptables -L -v -n command.

Chain INPUT (policy ACCEPT 141K packets, 33M bytes)
pkts bytes target     prot opt in     out     source               destination                                
    0     0 ACCEPT     udp  --  virbr0 *                                            udp dpt:53
    0     0 ACCEPT     tcp  --  virbr0 *                                            tcp dpt:53
    0     0 ACCEPT     udp  --  virbr0 *                                            udp dpt:67
    0     0 ACCEPT     tcp  --  virbr0 *                                            tcp dpt:67

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination                                
    0     0 ACCEPT     all  --  *      virbr0            192.168.122.                               0/24    state RELATED,ESTABLISHED
    0     0 ACCEPT     all  --  virbr0 *                                  
    0     0 ACCEPT     all  --  virbr0 virbr0                                    
    0     0 REJECT     all  --  *      virbr0                                            reject-with icmp-port-unreachable
    0     0 REJECT     all  --  virbr0 *                                            reject-with icmp-port-unreachable

Chain OUTPUT (policy ACCEPT 93365 packets, 14M bytes)
pkts bytes target     prot opt in     out     source               destination

To me honest, I have no idea what half this means, so any help explaining it would be great.

Also, I have been running the server without debug mode for a little while now, no difference. I have also contacted my server provider, to find out if my server has any form of NAT involved.

Signing off,

UPDATE: My server isn't behind any form of router or NAT.
The output from your iptables shows that you don't have firewall blocking connections. All but two rules are of type "ACCEPT" and won't block connections. Then there are two "REJECT" type rules, but they are in firewall chain FORWARD, which is related to NAT'ing (which does not mean you are or have NAT problems). Everything is OK there.

The output shows that the firewall rules are using network interface "virbr0". What other network interfaces do you have? Write "ifconfig" and paste the output. The name "virbr0" suggests it's "Virtual Bridge 0". You probably have VPS (Virtual Private Server), right?

My guesses this far:
* When you start the game, it binds to wrong network interface, which is somehow limited and can't connect to master servers.
* There is firewall/router/NAT after all, but your ISP doesn't know it Smile
* Your server is in the server list, but you don't search it enough. Make sure you wait for the whole list to load and then do eg. mapname filtering and try to find your server.

eth0      Link encap:Ethernet  HWaddr 00:16:76:08:B8:9C
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::216:76ff:fe08:b89c/64 Scope:Link
          RX packets:1359849 errors:0 dropped:0 overruns:0 frame:0
          TX packets:537726 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:363453411 (346.6 MiB)  TX bytes:80478865 (76.7 MiB)

ham0      Link encap:Ethernet  HWaddr 56:34:0D:40:86:1D
          inet addr:  Bcast:  Mask:
          RX packets:105487 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42467 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:10347392 (9.8 MiB)  TX bytes:5481340 (5.2 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:730 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:216384 (211.3 KiB)  TX bytes:216384 (211.3 KiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:11384 (11.1 KiB)
I can't think of anything then.

Actually it's already in your first post that "Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL", which means the server binds to correct IP address.

If the server was my own, I would uninstall / disable Hamachi (ham0, and Xen (virbr0,

There's no clear reason why your server can't connect to Steam master servers.
Well, this is odd. Anyway, Hamachi was installed after this problem occured, so that's not it, but I'll try and disabling Xen and see if that helps.
Ok, I have removed Xen, and found out that virbr0 is a nateral part of CentOS 5. Also, here is my server.cfg and server start commands, just to be sure it isn't any of those.

CSS Server.cfg

// server name
hostname "Swatmajor1 HQ CSS #1 ALLTALK+BOTSx2"

// rcon passsword
rcon_password "***********"

// Advanced RCON
sv_rcon_banpenalty 15
sv_rcon_maxfailures 10
sv_rcon_minfailures 5
sv_rcon_minfailuretime 45

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 0
mp_tkpunish 1
mp_forcecamera 0
sv_alltalk 1
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 5
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

//Bot Settings
bot_quota 3

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 5

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

CSS Server Launch Command

screen -A -m -d -S css-server ./srcds_run -console -game cstrike -ip +maxplayers 16 +map de_dust2

Well, I hope that my servers will be able to join the net soon, I really want to give my clan members game servers they can be proud of.

Signing off,

I tested Port 27011 using a program called listen_print and Quetannon, and I couldn't establish a connection.

I did test it on other ports used by Source, 27015, 27030, and they all connected. So, either iptables isn't configured properly (which I doubt), or there is some other firewall-like program which is blocking this port.

Well, hopefully I should have this fixed soon.
Well, it's been about a week, and I have tried everything I (as well as others) could think of. If there is anyone who has any insight to this problem, please, help.

Also, I can not view my server in the internet list. It is set to region 5, Australia, and is called "Swatmajor1 HQ CSS #1"

It is on, so if you can get to it, let me know ASAP!!!!

Forum Jump:

Users browsing this thread: 1 Guest(s)