SRCDS Steam group

Ubuntu Core Dump "Can't read pathname for load map"
Hey all, I'm getting the following output when I try to run srcds using this command:
./srcds_run -console -game cstrike +ip +maxplayers 11 +map cs_italy -autoupdate -debug

Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Server will auto-restart if there is a crash.
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 68
Checking/Installing 'Base Source Shared Models' version 4
Checking/Installing 'Base Source Shared Sounds' version 4
Checking/Installing 'Base Source Shared Materials' version 8
Checking/Installing 'Source Dedicated Server Linux' version 90

HLDS installation up to date
Illegal instruction (core dumped)

warning: Can't read pathname for load map: Input/output error.
email debug.log to
Thu Apr 17 23:28:24 MDT 2008: Server restart in 10 seconds

I've looked everywhere, and it seems that others are having the same problem, but I've yet to find a solution. Any help would be great! Thanks
try loading a different map?

also check to make sure that the user you are running under has full permissions to all of srcds and its subdirs
Ya, tried a bunch of different maps, and I'm trying to run the server as root, so I don't think it's either of those.

Also, it might not have anything to do with the map. I'm seeing the same error showing up with things not related to srcds server at all... looks like a pretty common seg fault error.
make sure your glibc is upto date?
looks like it's probably caused because my CPU doesn't support the SSE instruction set, and I guess it's required by srcds under Linux (although not under windows apparently). Looks like I either have to upgrade my CPU or install Windows.

Forum Jump:

Users browsing this thread: 1 Guest(s)