SRCDS Steam group

Random Startup Fails
I start my server using the following command:

./srcds_run -game cstrike -ip -port 27015 -maxplayers 12 +map de_dust2 -tickrate 100

I would say about 25-50% of the time, my server fails to start up. It hangs before the "adding master server" messages. The rest of the time, it starts up great and I see those messages without a problem.

When it does start up fine, people can connect without issue, the server autoupdates, etc. The rest of the time, the server just hangs before the point where those "adding master server" messages show up, and no one can connect.

I'm using Ubuntu 8.04 (Hardy Heron), if that helps. Admittedly, I'm fairly new at running Linux, but any help would be appreciated here, as this makes it impossible for me to run my autostart config, as the server will hang.
You start the server with local ip....try your wan ip: or ifconfig on linux (eth0 in most cases)
Well I'm behind a router, so my eth0 IP address is When I try to bind to my WAN IP (obtained from, I get the following error:

WARNING: NNET_OpenSocket: bind: Cannot assign requested address
Couldn't allocate dedicated server UDP port

The server does not start when you get this error, it just keeps attempting to rebind. I don't see how I can bind to that IP unless I forgo the router, which is not an option.

And just to reiterate, binding it with my LAN IP causes everything to start up fine MOST of the time. People can connect to my WAN IP without issue. It is just those seemingly random times that the server doesn't start properly that things go awry.

Forum Jump:

Users browsing this thread: 1 Guest(s)