SRCDS Steam group

creating user error
I have a suse linux box that i am try to make into a dedicated server for cs source. when i run the setup program i get the following:

linux:/srcds_l # ./steam -create password "my question" "answer"

Then i get this

Checking bootstrapper version ...
Creating Account
AuthenticationServerRSAPublicKey failed signature verifcation

then it just drops me back to linux:/srcds_l #

I am running suse 9 ent server(amd64) on a AMD 64 3000+ 1 gig ram 40 gig hdd
gcc 3.3.3 ldd 2.3.3 kernal
any ideas
You should use the more detailed syntax, you should also define a username too:
./steam -command create -username randomusername -email -password randompassword -question "Question?" -answer "Answer!"
May the Source be with you...

Want to know which ports to forward on your router for a Source DS? Click here!
I tried it with the old binary, first i tried
./steam -create <my aol username> <mypassword> <my question> <myasnwer>

so it was something like this (these are fake values)
./steam -create ok ok ok

and it said Please enter a valid email address.
so i changed the 1st to <>
and instead it gave me the error
AuthenticationServerRSAPublicKey failed signature verifcation

Also with the new binary the help listed no create command, and both
./steam -create
./steam -command create
were not recognized, so I skipped striaght to trying to install the dedicated server with

./steam -command update -game "Counter-Strike Source" -dir . (note i've used almost every dir)
and then it says
Checking bootstrapper version ...
Updating Installation

and eventually after like 5mins says "Receive Failure"

Also I deleted the directory ~/.steam and everything in it multiple times, just in case that .blob file was getting in the way.

I've checked everywhere for that error msg and no one seems to have anything good to say about it.
Note: I took down my firewall and that didnt help. I tried running it as root (only once or twice) but that didnt help either.

Any help would be greatly appreciated.

Edit: running FreeBSD 5.2.1-RELEASE
gcc (GCC) 3.3.3 [FreeBSD] 20031106
used to run CS 1.6 server, so I know it's possible.
I thought creating a user for srcds wasnt neccessary anymore.

Anyways, sounds like you may have a bad steam binary. Theres a link to a good one somewhere in these forums.
United Strike Marine Corps
USMC-CO| θ (theta)
Quote:-bash-3.00$ ./steam -command update -game "counter-strike source" -dir .
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 30

Checking/Installing 'Base Source Shared Models' version 3

Checking/Installing 'Base Source Shared Sounds' version 3

Checking/Installing 'Base Source Shared Materials' version 5

Checking/Installing 'Linux Source HLDS' version 33

HLDS installation up to date

No user needed Toungue
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.

Forum Jump:

Users browsing this thread: 1 Guest(s)