SRCDS Steam group

Mod based on SDK Base seems to be using HL2DM engine
I'm working on a Source Mod called Jailbreak and I'm experiencing a weird issue that I'm having real trouble solving...

Basically the issue is as follows; our mod is based on the HL2MP code originally, but we set the SteamAPPID in Gameinfo.txt to 215 so that it should use the SDK Base engine and materials as recommended.

This was working fine up until recently, with Steam showing "Preparing to launch <mod name>" when starting the mod, and crash dumps going to the SDK Base directory.

Recently however, our windows dedicated server had to be reinstalled, and since then we're unable to join the dedicated server from in game, with the error "Your version does not match the servers. Please restart the game".

You can join the server from the server browser in Steam outside of the mod, but on lauching the mod it reports "Preparing to launch Halflife 2 Deathmatch" instead of the actual mod name, although you do get in to the mod and it generally functions ok.

Crash logs also end up the HL2DM directory instead of SDK Base, and the mod has been crashing a lot more than before this started happening. The crashing is a real issue as it makes the mod almost unplayable, and looking at the crash dumps it shouldn't be crashing in the places it is.

We've also tested this with an older version of the mod which we know worked (and didn't crash), and that has the same problems. This leads me to believe that it's a server configuration issue, but I can't see how else to setup the server. We've tried it on 3 different machines, all with the same results.

I've been installing the srcds with the following command:
hldsupdatetool -command update -game "hl2mp" -dir .

and started the game with:
srcds.exe -console -game jailbreak-dev +map jb_metropolis -maxplayers 16 -autoupdate

One final oddity is that this is only a problem with the standalone dedicated server, as starting a dedicated server from within Steam works fine, and can be joined from within the mod etc.

Any ideas what it is I'm doing wrong? Let me know if there's any other information that would be helpful.
Thanks for your time!

Forum Jump:

Users browsing this thread: 1 Guest(s)