SRCDS Steam group

[SOLVED] Weird problem - please help
OK, so I'm on Linux Ubuntu server edition. Had some problems with setting it all up (srcds, static IP, forwarding ports) but it seems to be installed right now. Here's what happens when I fire up the srcds:

frespa@frespa-server:~/srcds_l$ ./srcds_run -console -game cstrike +map de_dust -maxplayers 16 -autoupdate
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 68

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Source Dedicated Server Linux' version 90

HLDS installation up to date

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 16
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
net.cpp (960) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cSendBufSize <= iVal
net.cpp (968) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cRecvBufSize <= iVal
Unknown command "pausable"
Unknown command "sv_rate"
Server logging enabled.
Server logging data to file logs/L0321010.log
L 03/21/2008 - 20:31:15: Log file started (file "logs/L0321010.log") (game "/home/frespa/srcds_l/cstrike") (version "3224")
L 03/21/2008 - 20:31:15: server_cvar: "sv_contact" ""
Adding master server
Adding master server
L 03/21/2008 - 20:31:17: World triggered "Round_Start"
Connection to Steam servers successful.
VAC secure mode is activated.


So it seems to be right, but I can't seem to find my server? I've tried my external IP, some different LAN IPs, and looking under the LAN tab in Steam (from another computer). What is wrong / what have I done wrong?

Thanks in advance.
Hi again,

so I found my server at, but that's an LAN IP isn't it?

Here's the ports I have forwarded - all to .5:

UDP 1200-1200
UDP 27000-27015
TCP 27030-27039
UDP 27015-27020
TCP 27015-27015

- is that correct?
tell your server what ip it is -ip and your ports look correct
Hi! Thanks for the quick response. Sadly it didnt work. I'm kind of lost here. Sad Must be something with the ports I guess... Or the server...

Check out and make sure you got all the right ports. Also, don't forget to check your actual server itself, as I'm sure by default ubuntu turns a restrictive firewall on. Try running:


and if you get a ton of results, then your firewall is active, and you should try:

iptables-save | grep 27015

Just to make sure that port is even open; if you see nothing after that command, then you haven't forwarded the ports on the server itself.

i dont think ubuntu installs with a firewall

try and changing my - to a +:

Well since neither of us are sure, he should probably run iptables-save just to see. Also for srcds, -ip works just fine as it is the newer form of the 'ip' variable, +ip is considered old and should be used for goldsource games.

Sorry if that sounded jerkish, just trying to clarify Smile
OK, tried that, no change. Maybe I should try my external IP? I dont wanna make a LAN server if that was not clear.
Hello deviantlinux.. What is the exact command I should run?

EDIT: I am now almost certain its the server. Tried running an apache server and I could access it from the external IP.
Try your external IP, and if that still doesnt work, just forward 27000-27039 TCP _and_ UDP. Plus 1200 for steam friends, and 26901 for the master server query. Did you forward 26901 in/out before? Give that a try also.
Hi again, I decided to use the DMZ option on my router, and it worked! (the function opening all ports you are using)

Thanks for all responses.

Forum Jump:

Users browsing this thread: 1 Guest(s)