SRCDS Steam group


Source TV Problems
#1
Hi Guys,

I have a few problems with my source tv, i have the auto recorder set to 1 however since it didn't work i thought i would manually record a game via tv_record with the sourcetv bot active.

I get the following error

CDemoFile::Open: couldn't open file tet.dem for writing.
StartRecording: couldn't open demo file tet.dem.

From what i gather thats a permission problem, anyidea what permissions need to be changed? (also how would be nice Smile

Secondly

I've also noticed that for TF2 servers, when source tv is active and you look in the steam server browser it shows the server when you click view info as 'source tv' - which is the sourcetv bot nane not the actual server name.

For an example please add 202.131.94.75:27060 (BestGN | TF2 #5 Promotional) to your fav list

when you press view info it shows up as 202.131.94.75:27025 'Source TV'

However when you join it directs you to the game server.


All help will be greatly appreciated


Thanks
Reply
#2
Anyidea why sourcetv cant record?

Anyone?
Reply
#3
Be sure to set +tv_enable 1 and +tv_port 27020 on the command line...this ensures it's running and running on the correct port. You can change the TV port, but be sure to differentiate between the game port and the TV port.

As for permissions, stop your srcds daemon, login as the user who runs the server daemon, and run

chmod u+rw srcds -R

This will change the permissions for the current user (u) and change all the files in the folder 'srcds' recursively (-R) to be read and written (rw). Now you may restart the server with the options I mentioned in the beginning and your sourceTV should be up + recording/saving.
Reply
#4
great, thanks for the reply.

I'll try it out now
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)