SRCDS Steam group

server will not show up on lan or internet (gametiger/steam)
Hey i know theres about 1000000 posts about servers that dont show up on the internet but i have been searching for about 2 days now and still have yet to find a solution. Im currently running redhat 9 and i have srcds installed (/srcds/srcds_l <- folder installed into).

When ever i go and try to start the server using "./srcds_run -game cstrike +ip -port 27015 +map de_dust2 +maxplayers 12" i just get error saying:

WARNING: NNET_OpenSocket: bind: Cannot assign requested address
Couldn't allocate dedicated server UDP port

i am running with a d-link DI-604 4-Port Boardband Router and i have the DMZ open to the internal ip ( as well as the required ports for the dedicated fowarded. can anyone PLEASE help me fix this problem. I get the same thing when i try it with HLDS! Also i know the box is accessing the internet because i have a website hosted on it and can see the site from the web.

GCC: 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
GLIBC: 2.3.2
KERNEL: Linux localhost.localdomain 2.4.20-8

Thanks in advance for any help and sorry if this is a stupid question Smile P.S. if you need any other info or pics from my router just post or drop me a line at
[Image: firearrow.gif]
- Alan \"FireArrow\" Stadtlander (eZ | FireArrow <> Amplified Networks CEO)
You're behind a router, IIRC you don't need the ip switch
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
ok ty for the help cryotek i guess i just wasnt thinking =P but now the server shows up on port 60390 =/ even though i specify it as -port 27015 when starting. any ideas how 2 fix?

Wink Probably another stupid question.
[Image: firearrow.gif]
- Alan \"FireArrow\" Stadtlander (eZ | FireArrow <> Amplified Networks CEO)
i am having exactly the same problem, my server works fine but i can't see it on server list, if i specify -ip <external ip> i get the same error as you did above about unable do assign udp

however this is supposed to be the fix if u're behind a router, see:​fY2F0cz01NyZwX3B2PSZwX2N2PTEuNTc7Mi51MCZwX3NlYXJjaF90eXBlPWFuc3dlcnMuc2VhcmNoX25​sJnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9Y2Fubm90IGFzc2lnbiByZXF1ZXN0ZWQgYWRkcmVzcw**&p_li=&p_topview=1


any more feedback on how to set this up?
i had this problem to and it really fudged the performance of my servers once i got them up. do this

in root type "ps aux --forest" it should list all running process and there PIDs and some more info
Look for srcds running kill any ones you dont running by typing
"kill -9 PID"

I did the ps aux and found out i had about 10 srcds running thats why those ports couldnt get used, i killed all the ones i didnt want running and server runs faster and i can use the ports
what is root and how do i get there
I recall getting the same error with a Ventrilo server. I searched the forums and found out that something else is already using those ports.
U only need to do like me...the only prob iz until il finde the steam make him no steam... fallow this commands

i mark them...i think they will work...if not go here

mkdir srcds
cd srcds

chmod +x hldsupdatetool.bin


ln -s /usr/bin/gunzip /usr/bin/uncompress

./steam -command update -game "Counter-Strike Source" -dir .


./srcds_run -console -game cstrike +map de_dust +maxplayers 20 -autoupdate

./srcds_run -console -game cstrike +map de_dust +maxplayers 20 -autoupdate +sv_lan 1

Forum Jump:

Users browsing this thread: 1 Guest(s)