SRCDS Steam group

Server crashed when webmin or ssh closes
Hi Guys,

I have been running a TF2 server for 4 months or so now without hardly any problems. I am running on Debian 4.0, and use a custom command function in Webmin to start my server:

./srcds_run -console -tickrate 66 -game tf +ip -port 27115 +maxplayers 24 +map ctf_2fort

I would then close webmin, and reboot my server daily in HLSW with the 'quit' command. Everything has been fine until the latest update. Now unless webmin stays open after launching the server, the server crashes on map change. If I type 'quit' in hlsw, the server crashes, if I use Mani to change map in-game the server crashes, if I use HLSW to change map, the server crashes.

The same happens if I use ssh to launch the server, everything runs fine until I close the connection!!

Any ideas??
Here's the log output:

exec: couldn't exec banned_user.cfg
exec: couldn't exec banned_ip.cfg
exec: couldn't exec ctf_2fort.cfg
Adding master server
Adding master server
Using 'steambeta1:27013' CSER server!
Connection to Steam servers successful.
   VAC secure mode is activated.
HLSW : Test
rcon from "": command "echo HLSW: Test"
Usage:  log < on | off >
currently logging to: file, console
rcon from "": command "log"
rcon from "": command "logaddress_add """
rcon from "": command "logaddress_del """
rcon from "": command "logaddress_add """
rcon from "": command "quit"
L 12/22/2007 - 20:41:01: server_message: "quit"
L 12/22/2007 - 20:41:01: Log file closed
L 12/22/2007 - 20:41:01: server_message: "restart"
Reference Count for Material __particlesdepthwrite (1) != 0
Sat Dec 22 20:41:01 GMT 2007: Server Quit
there's no mention of using the screen command whilst using ssh, are you doing so? else the server will obviously quit when you close the connection.
Ahhh, I only tried ssh when all other methods were failing.. That would explain that.

When I launch using webmin the server is fine until a map change occurs using any of the methods available, ie automatically, using HLSW, or Mani. I have tried without Mani, or MMS installed with the same result...
What do I need to add to this cmd line to run the server using screen??

./srcds_run -console -tickrate 66 -game tf +ip -port 27115 +maxplayers 24 +map ctf_2fort

Many thanks.
you can either do screen -dmS server1 blah blah or do screen -S server1 (which will open a new screen named server1) start your server, then do ctrl a + d to detach.
Many thanks, sorry to be a pain but this is all new to me.

I can do this as root, but how do I give permission to my user to use screen? I get the error:

Cannot open your terminal '/dev/pts/2' - please check.

Plenty of results in Google explaining the error, but not how to change the users permission!

Forum Jump:

Users browsing this thread: 1 Guest(s)