SRCDS Steam group

Source install on FreeBSD 5,3
I have been trying to setup a cs source server on my rig, but it never gets past ./steam ... heres the logs:


$ wget --06:09:35--
=> `hldsupdatetool.bin'
Resolving done.
Connecting to[]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,981,254 [application/octet-stream]

100%[====================================>] 2,981,254 567.85K/s ETA 00:00

06:09:45 (567.85 KB/s) - `hldsupdatetool.bin' saved [2981254/2981254]

$ chmod +x hldsupdatetool.bin
$ ll
total 2932
drwxr-xr-x 2 cssource cssource - 512 Mar 15 06:09 ./
drwxr-xr-x 4 cssource cssource - 512 Mar 15 06:09 ../
-rwxr-xr-x 1 cssource cssource - 2981254 Oct 11 18:44 hldsupdatetool.bin*
$ ./hldsupdatetool.bin

===================== LICENSING INFO =====================

Enter 'yes' to accept this agreement, 'no' to decline: yes
extracting steam...done
$ chmod +x steam
$ ./steam

Create a Steam Account:
-create <username> <password> <question> <answer>

Install or update HLDS:
-update <game> <installdir> <username> [<password> [Y]]
Y => remember password

View installed versions:

really confusing, and I have loaded Linux from Port and compiled from source....

any ideas?
try ./steam update or ./steam -update
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
gave the same thing
The ./steam command line the tutorial has is out of date and won't work BECAUSE the steam executable installed by hldsupdatetool.bin is old and needs an update before it will work.

Try this:

1) ./steam -update or ./steam update which ever works I forget.

2) ./steam -command update "Counter-Strike Source" -dir . -verify_all

3) but first read

If you run into the 'compression failure' problem you will know how to quickly work around it Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)