SRCDS Steam group

Need Help! Expert Advise
Title says it all, need someone that can help me with a few questions regarding some DS issues.

I say expert for i have done everything that is obvious and have been setting up HL servers since the game came out on both Linux and Windows boxes..

Go through the hldsudpate bs (20 times now) fresh install, create a shortcut of the srcds file and add the appriate tags.

C:\TF\orangebox\srcds.exe -console -game tf

For now lets keep it simple, and yes I have tried with all the +map +maxplayers -port -ip blah blah blah..

Go to double click the Srcds.exe shortcut and nothing happens. Doing this exact same thing for the other CSS Servers that are on this box and they start flawlessly. They are all shut down and now uninstalled in my attempts to fix this problem with the TF DS.

Please if anyone has and respectable advice pm me directly or state it here.


does it work if you start the server from a command line?
CD C:\TF\orangebox
srcds.exe -console -game tf

And make sure you have the path correct...
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Nope, just immediately goes back to the c:\TF\Orangebox command line with nothing in the respect of errors.

Beginning to think TF has some kind of code check for hardware requirments, i know im reaching but i cant think of any other reason it wouldnt start the srcds console when the CSS and DODS start with zero problem.
sounds like some files are missing corrupted, did you try install with -verify_all?
Dozens of times, -verify_all is garbage atm with the instablity of the d/l servers.. It just loops infinately through the same directly when you push the up arrorow and start again after the winsocket error.
that's really the only thing you can do at the moment, i had to do my tf2 install about 9 times and that was either late night or early morning (for me). during peak hours it just wouldn't download anything.
Would it help if I make a torrent of the files and upload it? My server is working, so if you want I can.
I appreciate that but i seriously dont think its anything to do with the files, i did the very same d/l here on my computer and it worked flawlessly the first time.

I dunno what it is but the damn console just wont come up, i have tried everything i know and after 20 fresh installs of the god damn thing i have to say a server for that pos game isnt that important anymore.
Alright. Well, if you're tempted you can get it here. I'll be seeding it for a while. Anyone else who wants it can get a go for it from there. Note it is the Windows not Linux install.

Also, since you run multiple other servers, perhaps you could answer my question. I can only join my servers (both CSS and TF2) over lan. Never see them online. Anything I have to do in particular?
sv_lan 0 ???

Otherwise, I think they are correct in the missing files assumption.
|GsX| GrimReaper Wrote:sv_lan 0 ???

If you are talking to me, I do have that set in my server.cfg.
that guy Wrote:
|GsX| GrimReaper Wrote:sv_lan 0 ???

If you are talking to me, I do have that set in my server.cfg.

My apologies...I had multiple pages and the sv_lan was pertaining to another very similar thread.

I installed TF2 last night on our box. I waited until 1am, and still had MULTIPLE issues with the hldsupdatetool quitting prematurely. Finally got it to go to 100% and then did the verify multiple times before it finally made it all the way through.

Never had a single issue after that. I was disappointed that at first attempt it did nothing due to the install location not existing. In the past, the tool would create the folder I desired.

I use FireDaemon to run my servers as services on Windows 2003 Server, but the command line functions are the same. This is my config.

-console -game tf +ip +maxplayers 24 +map cp_dustbowl -tickrate 100 +fps_max 600 -notv -nocrashdialog

I believe a map is required, and that is your problem. In my config, I don't do the port, so it defaults to the next available, starting with 27015, and so on.

For the ticrate and fps_max to do anything, you must be running srcdsfpsboost.exe
so what happens if you open a command window and type the start line?
fqdn Wrote:so what happens if you open a command window and type the start line?

I don't know that steam.exe would be automatically registered in windows, etc, that you could simply try to execute it without the full path, but if you were to click start, run, cmd, then in the cmd window try:

cd Path_to_server_install

then type steam.exe -console -game tf +ip your_server_ip +maxplayers 24 +map cp_dustbowl -tickrate 100 +fps_max 600 -notv -nocrashdialog

It should launch fine. The server needs boosted for tickrate and fps to give any noticable changes.[/i]

Forum Jump:

Users browsing this thread: 1 Guest(s)