SRCDS Steam group

Please update Lionux guide
Apparantly there is a new version of steam so now the syntax for creating and updating is different from the guide..

So please update the guide....the wget command also doesnt work on my Linux Debian box...

probably because you don't have it, try apt-get wget or see if you have fetch installed.

But if you look at it, it says what the syntax is when you have it upgraded, and i think steam still has the older version on their servers.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Can the tutorial be updated to mention that you need to update steam right away and use the new syntax?

A wrong tutorial is worse than no tutorial.


someone please post old/new command syntax WITH examples. trying now for an hour to get a) steam updated and b) setting up a new account, no idea whats wrong.

refering to the output u get when just executing "./steam" i tried:
./steam -create user mail pw q a
./steam -create user pw q a
(yes with no email, following ".steams" syntax
Create a Steam Account:
        -create <username> <password> <question> <answer>

s/o just paste example please, almoast broke my keyboard Toungue

yea, im having same problem.... what is the exact command for updating a linux cs:s dedicated server?
gasxtreme Wrote:yea, im having same problem.... what is the exact command for updating a linux cs:s dedicated server?
./steam -command update -game "Counter-Strike Source" -dir . -username <username> -password <password> -remember_password

This one works perfect at my box.
May the Source be with you...

Want to know which ports to forward on your router for a Source DS? Click here!

That syntax no longer works, here is the command I use to try and update my server

Quote:srcds@atomsk:/home/srcds # ./steam -command update -game "Counter-Strike Source" -dir . -username philodoxx_server -password mypassword -remember_password

and I receive this message:

Quote:Checking bootstrapper version ...

Create a Steam Account:
-create <username> <password> <question> <answer>

Install or update HLDS:
-update <game> <installdir> <username> [<password> [Y]]
Y => remember password

View installed versions:
What worked for me:

1) Create a brand new user on your server box.

2) Log in as this user.

3) Make an srcds folder

4) From inside the folder:


5) chmod +x hldsupdatetool.bin

6) ./hlupdatetool.bin

7) chmod +x steam

8) ./steam -update

9) ./steam -command update "Counter-Strike Source" -dir . -verify_all

If you encounter the Compression Failure problem, see the sticky thread at the top of the forum.

NOTE I didnt have to use any -login -question arguments. Never did for this entire install attempt. Maybe Valve changed that login requirement? Mine was a new install, not an update. Maybe folks updating can still use the -username -password stuff, but I sure couldn't. Also, previous attempts installing as root didnt work. I succeeded when I used a fresh user account on my server box.
that fixed mine as well, thanks! Smile

Although I'm curious why the account had to be deleted first for it to work.

Forum Jump:

Users browsing this thread: 1 Guest(s)