SRCDS Steam group

steam and hldsupdatetool
Hey everyone, trying to install another copy of source on my box here, however running into a little bit of trouble.

After downloading the hldsupdatetool, excecuting it, and attempting to create my username and password, I'm greeted with the following output.

Checking bootstrapper version ...

Create a Steam Account:
        -create <username> <password> <question> <answer>

Install or update HLDS:
        -update <game> <installdir> <username> [<password> [Y]]
         Y => remember password

View installed versions:

Now, I've tried running ./steam -update Same output.
I've tried the command supplied in the tutorial Same result.

After doing a ./steam -version I come back with
Bootstrapper version: 12

Now as I said I've recieved the update tool directly from valve... is there a new syntax that now needs to be used, and I'm just not smart enough to figure it out?

Thats the old hldsupdatetool. Thats been addressed several times in the forums already. Easy solution is download a newer version of the updatetool. Either that or use the one you have. syntax would be as shown in your post.

./steam -create someuser someuserspassword "some users secret question" "some answer"

after you do that, it should download the newer version of the hlds update tool.

but from what I am reading, this is not your first install on the box, and you have an existing srcds. Is that right?

well, if you have an existing srcds, why not just copy the old one? it would probably save you a lot of time.
United Strike Marine Corps
USMC-CO| θ (theta)
thought about that... but after attempting that steam command it bitches about enter a valid email addy. I've tried adding an email in quotes and outside of quotes every single place that I can think of in that command, but no dice.

from now on, gonna just cp -R * to the new dir. However does steam keep a record of the install path somewhere that i might have to change that variable?

wow, I have never used a valid email address for hlds or srcds.

just after you copy the directory, cd to that directory and run the ./steam -command update etc. with the right directory. you should be fine after that.
United Strike Marine Corps
USMC-CO| θ (theta)

Forum Jump:

Users browsing this thread: 1 Guest(s)