SRCDS Steam group

very high CPU usage
Hi. I run a GSP and i'm having big trouble with SCRDS (version in Linux CentOS 5. I already compiled Kernel to 1000Hz Preemptive (User 1000Hz) High Resolution Timer. The server is a Dell Poweredge 1850 with Dual Xeon 3.2GHz 1MB Cache (Hyper-Threading Off; bogomips: 6384.04 each) and (still, it'll be upgraded soon) 1GB of memory

Source Dedicated Server (no addons) tends to use more CPU power than it should, even while idle it wastes 14% or more of CPUs and 16% of memory usage.

12606 xxxxxx 15 0 308m 175m 10m S 13 17.3 274:09.05 srcds_i686

It runs on Tickrate 100 and whilst full it uses 60 to 70% of CPU resource. When the server is full people complain that the server is breaking and totally unplayable, and they go away. Even if i run it at Tickrate 33 the load seems to be excessive.

The same thing is happening with HLDS, a full 12 users server uses average 17% of CPU usage, and it can go as high as 21%

18324 xxxxx 15 0 75544 65m 4740 R 21 6.5 80:17.85 hlds_i686

While idle, HLDS usually wastes:
6104 xxxxx 15 0 122m 80m 3876 S 5 8.0 66:33.77 hlds_i686

This machine is completely dedicated to the GSP and there's nothing running except Lighttpd and Proftpd.

Have i abused on the kernel optimization settings? What could cause this?

Antonio Nobre
One thing that i can think, it's maybe that you choose the bad CPU family at the kernel option,

do : less /proc/cpuinfo and tell me which CPU Family did you choose!

Often, wrong CPU family can cause thing like that, cause the kernel isnt optimized for your CPU architecture ...

which kernel of CentOS5 do you use? Do you use the one that come with it (2.6.18) or a new one from
Cpu family is correctly selected

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 3
model name : Intel® Xeon™ CPU 3.20GHz
stepping : 4
cpu MHz : 3192.358
cache size : 1024 KB

I'm using the new from, with High Resolution Timer, the scheduler is Anticipatory, user HZ is 1000Hz (from param.h) and timer is 1000Hz. Using CFQ as scheduler produces the same result or even worse.

I don't think it's bad hardware. Also it seems not to be caused by lack of RAM memory and paging of it in the HDD.

Ok, i know this won't help you ... but can you tell me how you modified the param.h plz??

For your problem, i don't really ... maybe it's only server.cfg problem, post it there!
Whilst in the kernel directory,

vi /usr/src/kernels/linux-

define "USER_HZ 100" replace to "define USER_HZ 1000".

The problem isn't related with server.cfg, as it happens with every single server.cfg.

This problem came up a while ago the mailing lists with an update causing high idle CPU usage. But it was fixed weeks ago :s

Stupid question, but you have updated the server recently, yes?
Thank you! Wink

I updated SRCDS this morning (GMT, Lisbon), i'm now waiting for someone to test it.

But i still got 20% of CPU usage with 16 users in to separated HLDS processes and that is something that i need to investigate.

18538 xxxxx 15 0 111m 104m 5900 S 18 10.4 117:44.71 hlds_i686

This HLDS instance is running AMX MOD X only. Seems ridiculous, a machine like this being junked with old software.


Forum Jump:

Users browsing this thread: 1 Guest(s)