SRCDS Steam group

Map Download Issue
To start off... my server.cfg

// server name
hostname "Xtreme Gaming CSS"

// rcon passsword
rcon_password "xxxxxx"

// Advanced RCON
sv_rcon_banpenalty 30
sv_rcon_maxfailures 3
sv_rcon_minfailures 5
sv_rcon_minfailuretime 30

// server cvars
sv_downloadurl ""
mp_dynamicpricing 0
mp_friendlyfire 1
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 1
mp_tkpunish 0
mp_forcecamera 0
sv_alltalk 1
sv_pausable 0
sv_cheats 0
sv_consistency 0
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 0
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 45
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 3
mp_roundtime 2
mp_startmoney 3400
mp_c4timer 30
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 0

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 100
sv_minupdaterate 20

// server logging
log on
sv_logbans 1
sv_logecho 0
sv_logfile 1
sv_log_onefile 0

// bots
bot_quota 6
bot_quota_mode fill
bot_difficulty 0
bot_chatter normal
bot_auto_follow 1
bot_auto_vacate 1
bot_join_after_player 0
bot_defer_to_human 1
bot_prefix "[XG]"
bot_allow_rogues 0
bot_walk 0
bot_join_team any
bot_eco_limit 800
bot_allow_grenades 1
bot_allow_grenades 1
bot_allow_pistols 1
bot_allow_sub_machine_guns 1
bot_allow_shotguns 1
bot_allow_rifles 1
bot_allow_snipers 1
bot_allow_machine_guns 1

// operation
sv_lan 0
sv_region 1

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

The error I'm getting is the standard non existent map error.

The file structure is intact. You don't need to doubt me on this. These are the thing below that I have done to see if the issue would get fixed, and it has not.

-Creating a .res file
-Double checking what the host views the files as (.bsp as .txt)
-Added net_maxfilesize 32 to server.cfg file
-Change sv_pure to 1 and 0
-Changed Consistency to 0
-Straight download from server and not fast download location.

Do you have any suggestions? If would be easier on you, I am available on American Instant Messenger. My screen name is KH Joshua Hanes

Also I have a map changing issue. When I change my map to a custom map or normal map, it will change it to a completly random map. If I type changelevel de_dust it will got to dust2, or italy, or cbble. It is happening on every map change. I FIXED THIS, I HAVE TO USE THE COMMAND "MAP" INSTEAD OF CHANGELEVEL

Thank you.
The problem must be on your webserver end - 99% of the time it always is.

Are your maps on the webserver compressed in bz2 format? So the file extension .bsp.bz2?

I haven't heard anyone else have a problem with this on the mailing lists so i assume its just an isolated incident with the map change. The only reason it would not go to the map you told it to go to would be because it couldn't open the map properly so it would get to the next one in the list/cycle.

Try running hldsupdatetool again with the parameter -verify_all
The map is running fine with bots in it. As I stated above, I have tried disabling the fast download and still had the same issue, and yes I did restart my server after edit of server.cfg.

As for map compression no, they are not. I even tried using a standard map, de_dust, and still gave me the same issue.
Okay, this server is at my work, and I just checked it out and it's downloading just fine, but the fast download isn't working now. Ha ha. Gotta love this steam stuff. FUBAR Smile
Not really.. you have a misconfiguration somewhere on your webserver end. Either your clients are being blocked from the webserver or the sv_downloadurl folder/maps are not setup correctly.

Forum Jump:

Users browsing this thread: 1 Guest(s)