SRCDS Steam group

problem with running .cfg file with server
i seem to not be able to run my cfg with the server when it plays. the file is a cfg file and is in my C:\srcds\hl2mp\cfg folder. im not sure y that when i run the server it uses the default and doesnt pick up that i have a cfg file writen

any1 help?

If your cfg file is not named server.cfg it won't run unless you tell srcds to run it.

So, you could open the existing server.cfg and at the end add a line:

exec <newcfgfile.cfg>

Or if you want your new cfg file to replace the original one, just rename it server.cfg
hmm its still not working the file name is server.cfg adn its a cfg file and its in C:\srcds\hl2mp\cfg this is the config could you tell me whats wrong :s :

rat20.00 british time

// server name
hostname "******"

// rcon passsword
rcon_password "********"

// Server password
sv_password ""

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autokick 0
mp_flashlight 1
MP_timelimit 30
mp_teamplay 1
mp_forcerespawn 1
mp_fraglimit 200
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_gravity 250
sv_maxspeed 420
sv_voiceenable 1
mp_allowspectators 1
mp_chattime 5
sv_timeout 75
sv_stats 1
net_maxfilesize 65
sv_hl2mp_weapon_respawn_time 3
sv_hl2mp_item_respawn_time 10

sk_suitcharger "75"
sk_suitcharger_citadel "200"
sk_suitcharger_citadel_maxarmor "200"
sk_battery "15"
sk_healthcharger "50"
sk_healthkit "25"
sk_healthvial "10"

// player damage adjusters
sk_player_head "3"
sk_player_chest "1"
sk_player_stomach "1"
sk_player_arm "1"
sk_player_leg "1"

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 1
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 255

// execute ban files
exec mani_server.cfg
exec mani_quake_sounds.cfg
exec banned_user.cfg
exec banned_ip.cfg

exec <newcfgfile.cfg>
are you sure it's not named server.cfg.txt or something like that? you have to select the "show file extensions" in the folder properties to see especially if you used notepad to edit the file.
You didnt actually add:

exec <newcfgfile.cfg>

to it did you?

Replace <newcfgfile.cfg> with whatever your new cfg file is called.


exec mynewconfig.cfg

Forum Jump:

Users browsing this thread: 1 Guest(s)