SRCDS Steam group

Server crash (Illegal instruction) - SSE problem?
This crash happens pretty much whatever I try to run.

lanparty@DracServer1k:~/steam/srcds$ ./srcds_run -debug -game cstrike
Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Auto-restarting the server on crash
Illegal instruction (core dumped)
Cannot access memory at address 0xb7f296d0
Cannot access memory at address 0xbff10c70
/home/lanparty/steam/srcds/debug.cmds:3: Error in sourced command file:
Cannot access memory at address 0xb7f296d0
email debug.log to
Thu Jun 21 17:31:17 PDT 2007: Server restart in 10 seconds
Thu Jun 21 17:31:19 PDT 2007: Server Quit

CRASH: Thu Jun 21 17:31:17 PDT 2007
Start Line: ./srcds_amd -debug -game cstrike
Using host libthread_db library "/lib/tls/i686/cmov/".
#0  0xb7d45913 in ?? ()
No symbol table info available.
End of Source crash report

Distro: Ubuntu Server 7.04

gcc --version
gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
ldd --version
ldd (GNU libc) 2.5
uname -a
Linux DracServer1k 2.6.20-15-server #2 SMP Sun Apr 15 07:41:34 UTC 2007 i686 GNU/Linux

I've already tried re-updating and using verify_all.
Figured out the problem is likely that my processor doesn't support SSE. I tried -binary srcds_i486, but that didn't work either. I found out that Valve messed up and made even the 486 version require SSE, which is a bit impossible. Are there any known workarounds for running srcds on a non-SSE proc?

Forum Jump:

Users browsing this thread: 1 Guest(s)