SRCDS Steam group

Secure Mode???
Hi. For some reason I get a secure mode enabled message. What does this mean? It says Could not establish connection to Steam servers and no one can connect to the server from the internet. Even if i run my external ip in the run line. Instead I get a UDP error and never get a VAC Connection Sucessful message.

debian:~/home/gmod# ./srcds_run -console -game cstrike +map de_dust -port 27015 +maxplayers 22
Auto detecting CPU
Using default binary.
Auto-restarting the server on crash

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 22
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
net.cpp (960) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cSendBufSize <= iVal
net.cpp (968) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cRecvBufSize <= iVal
couldn't exec server.cfg
Adding master server
Adding master server
hostname: Counter-Strike: Source
version : 3140 insecure (secure mode enabled, disconnected from Steam3)
udp/ip :
map : de_dust at: 0 x, 0 y, 0 z
players : 0 (22 max)

# userid name uniqueid connected ping loss state adr
Could not establish connection to Steam servers.
Create a server.cfg, keep -ip in startup line make sure all correct ports are open. Theres about a bazillion threads relating to that recently for you to compare.
Ok. What should I set my -ip to? My internal ip? Now I seam to get a connection to steam servers and it says connection to vac servers secessful but people still can't connect to my server over the web. My internal ip address is dmzed.
Your -ip should be set your external IP address.

If your computer is in a dmz zone (speaking of the router term), then the only other thing stopping people connecting would be a software firewall.
Figured it out myself. Hmm. interesting. I set the ip as my internal ip ( and gave my friend my external ip and he was able to see and connect to my server.

Forum Jump:

Users browsing this thread: 1 Guest(s)