SRCDS Steam group

No master servers?
I just installed kUbuntu on a spare box, then tried installing a Counter-Strike: Source dedicated server. I usually run these off of FreeBSD, and usually have about 95% success with them working properly. However, this one's got me stumped. I have Meta mod and Mani Admin Mod running, and both appear to be working. Here's what I get when I run my server:

Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 61

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Source Dedicated Server Linux' version 75

HLDS installation up to date

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
Using conprintf
Loading Mani Admin Plugin 2006 V1.2BetaR SMM,

Interface IPlayerInfoManager @ 0xb6c285e8
Interface IVEngineServer @ 0xb74ad020
Interface IGameEventManager2 @ 0xb747d360
Interface IFileSystem @ 0xb7d9c040
Interface IServerPluginHelpers @ 0xb74a99a0
Interface INetworkStringTableContainer @ 0xb7487320
Interface IEngineTrace @ 0xb747d218
Interface IUniformRandomStream @ 0xb748e100
Interface IServerGameEnts @ 0xb6c179c8
Interface IEffects @ 0xb6c00650
Interface IEngineSound @ 0xb74b1b18
Interface ICvar @ 0xb747a620
Interface IServerGameDLL @ 0xb6c17844
Interface IVoiceServer @ 0xb74af86c
Attempting to load [./cfg/mani_admin_plugin/language/language.cfg]
Language to be used [english]
Searching for game type [Counter-Strike: Source]
Found gametypes for Counter-Strike: Source
Linux binary @ ./cstrike/bin/
Program Start at [0x80d8650]
var_address = 0xb6b4f988
Game Type [Counter-Strike: Source]
Message name Geiger index 0
Message name Train index 1
Message name HudText index 2
Message name SayText index 3
Message name SayText2 index 4
Message name TextMsg index 5
Message name HudMsg index 6
Message name ResetHUD index 7
Message name GameTitle index 8
Message name ItemPickup index 9
Message name ShowMenu index 10
Message name Shake index 11
Message name Fade index 12
Message name VGUIMenu index 13
Message name CloseCaption index 14
Message name SendAudio index 15
Message name RawAudio index 16
Message name VoiceMask index 17
Message name RequestState index 18
Message name BarTime index 19
Message name Damage index 20
Message name RadioText index 21
Message name HintText index 22
Sigscan info
A [0xb697eda0]
B [0xb67b0310]
C [0xb6c02da0]
D1 [0xb6c40784]
E [0xb65da090]
F [0xb697ac20]
G [0xb6973c70]
H [0xb68c8600]
I [0xb68efc40]
J [0xb68116a0]
K [0xb68ddd60]
Time for read = [0.000070]
Time for read = [0.000036]
Steam ID Player Stats memory usage 0.000000MB with 0 records
Name Player Stats memory usage 0.000000MB with 0 records
Bad line 1 in ./cfg/mani_admin_plugin/clients.txt
Failed to load ./cfg/mani_admin_plugin/clients.txt
maxplayers set to 32
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

All of that looks fine, but when I try to connect to it from my Steam account, I get something like the picture attached to my post. I can't connect to the server, and it says it's not responding. However, when I portscan the server, the port IS open.

Run Command
./srcds_run -game cstrike -pingboost 1 -autoupdate 1 -map cs_office -ip -maxplayers 32 -insecure

Uname -a
Linux spare 2.6.15-26-386 #1 PREEMPT Thu Aug 3 02:52:00 UTC 2006 i686 GNU/Linux


Attached Files
.jpg   z0mg.JPG (Size: 3.1 KB / Downloads: 6)
0hmy Wrote:Run Command
./srcds_run -game cstrike -pingboost 1 -autoupdate 1 -map cs_office -ip -maxplayers 32 -insecure

Pingboost has never been available in srcds. autoupdate is just a singular command - there is no 0/1 option - so remove the 1. Your maps should be called using "+map cs_office" and same for maxplayers (use a +, not a -).

./srcds_run -game cstrike -ip -port 27015 +map cs_office +maxplayers 32 [-tickrate 66] +fps_max 600 -autoupdate

Tickrate is also an optional extra.

Should work now..
Thanks, worked like a charm Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)