SRCDS Steam group

HL2 Clan server prob... help!!!!!!!
Hey guys,

I'm having a very bad day today trying to work out all these god damn problems. OK, I installed Source Dedicated Server using your linux guide on a AMD 1700+ box with Ubuntu 6.10. Updated it and installed hl2mp. When I first ran it using
./srcds_run -console -game hl2mp +map dm_runoff +maxplayers 16 -autoupdate
it ran fine, connected to steam master servers, etc. but it could not be found on the Internet nor the lan in steam. Then I found out about the ports and opened those ports in firestarter and forward those ports in my modem (SpeedTouch 530). I have a dynamic ip address. Started it up again and same results. I tried different startup commands but now it doesn't connect to any steam master server!

./srcds_run -console -game hl2mp +sv_lan 0 +maxplayers 14 -autoupdate

Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Half-Life 2 Deathmatch' version 23

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'Source Dedicated Server Linux' version 75

HLDS installation up to date

Console initialized.
Game.dll loaded for "Half-Life 2 Deathmatch"
maxplayers set to 2
maxplayers set to 14
Network: IP unknown, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Thats it! I have no settings?! whatever config file yet... I just want the server to run first!!!!!!!!!!!!!!

I have tried setting my current assigned ip from my isp but it says unable to assign ip or something and adding the port don't make a difference! My windows box on the other hand I can start the server find and join it via lan but friends can't join or see it via the internet!

Can someone please help me, its all messed up !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!​!!!!
Try to add a map in the command line.

./srcds_run -console -game hl2mp +map dm_powerhouse +sv_lan 0 +maxplayers 14 -autoupdate
thanks man, just not thinking properly today Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)