SRCDS Steam group

problem solved thanks to (fqdn)
Big Grin 
Hi, I’m new to this forum and I hope I can find some useful information about the trouble I’m having with my Linux dedicated server. There is a couple of questions I need answers for. The first one is about srcds dedicated server every time I try running it, this message appears:

Quote:> ./srcds_run -console -insecure -game cstrike -maxplayers 32 +map de_dust
sh: line 1: ./srcds_run: No such file or directory

I have fully installed the srcds dedicated server the way described on the srcds website. Can anyone help me understand what it is I have done wrong or missed out?

The second question I need answer for is how to keep the server running. What I mean is that every time I close putty (is the program I’m using to execute the commands) the server shuts down also. Now I kind of would like my server to keep going when I’m gone to sleep. This is very important for me and I would really appreciate answers to help me with my difficulties.
1) obviously you're either not in the right folder to run srcds_run or the file doesn't exist, do an ls in your current directory and see if srcds_run is there.

2) use the screen command for this, if you don't have it then you need to install it.
please i dont understand all of this i'm a TOTAL BIG NOOB! give me more details if you want to help me, i'm a good person.
you can't run srcds_run if it's not in the folder that you run the command from, i don't know how else to put it. like you go to make a peanut butter sandwich, you have no peanut butter = you can't make the sandwich. you need to change to the folder that you installed your srcds into and then run srcds_run, it should be in the folder that you specified as "-dir xxx" during the install.

you better google for the screen command to figure out how to use it. it's not that hard, try typing "screen --help" or "man screen"

maybe you should switch to windows?
Can you not give like a little tutorial to me please or a link to one would do fine.
I can figure out my first question, but the second one is what I’m having problems with, everywhere I see tutorials like ok you need to screen it and script this commands and so on but how can I do that if all they telling me is what to do and not how to do it!
Your the only person that answerd to my thread please give me something.
i don't know what to say, you have to learn on your own, i gave you the commands in my earlier post did you even try them? if you did what happened?

screen --help
man screen

first will give you basic help, second will show the man(ual) and tell you what it does. why don't you try looking for "how to use screen" instead of "how to run srcds with screen"
Good news i found out that my linux dedicated server has screen installed, the only thing i need now is hot to create this script and where to place it.
Even more good news i did this command you told me and this appears:

-a Force all capabilities into each window's termcap.
-A -[r|R] Adapt all windows to the new display width & height.
-c file Read configuration file instead of '.screenrc'.
-d (-r) Detach the elsewhere running screen (and reattach here).
-dmS name Start as daemon: Screen session in detached mode.
-D (-r) Detach and logout remote (and reattach here).
-D -RR Do whatever is needed to get a screen session.
-e xy Change command characters.
-f Flow control on, -fn = off, -fa = auto.
-h lines Set the size of the scrollback history buffer.
-i Interrupt output sooner when flow control is on.
-l Login mode on (update /var/run/utmp), -ln = off.
-list or -ls. Do nothing, just list our SockDir.
-L Terminal's last character can be safely updated.
-m ignore $STY variable, do create a new screen session.
-O Choose optimal output rather than exact vt100 emulation.
-p window Preselect the named window if it exists.
-q Quiet startup. Exits with non-zero return code if unsuccessful.
-r Reattach to a detached screen process.
-R Reattach if possible, otherwise start a new session.
-s shell Shell to execute rather than $SHELL.
-S sockname Name this session <pid>.sockname instead of <pid>.<tty>.<host>.
-t title Set title. (window's name).
-T term Use term as $TERM for windows, rather than "screen".
-U Tell screen to use UTF-8 encoding.
-v Print "Screen version 3.09.13 (FAU) 5-Sep-02".
-wipe Do nothing, just clean up SockDir.
-x Attach to a not detached screen. (Multi display mode).
-X Execute <cmd> as a screen command in the specified session.

Can you give me a tip on what I should be looking for…

Thanks for your help there is some crazy people out there that tried charging me $75 for this info!!!
Ok I’m having trouble with the below:

I made the script using this and saved it on my dedicated server on the root group.

echo "Starting Cs:Source Server"
sleep 1
screen -A -m -d -S css-server ./srcds_run -console -game cstrike +map de_dust +maxplayers 16 -autoupdate

After save I chmod it with the below:

chmod +x

But for some reason it says:

chmod: failed to get attributes of `': No such file or directory

It looks like the file is in the wrong directory, when I followed the srcds tutorial it never explained where to save this file!
you've got to be kidding me, if the script is calling srcds_run, don't you think it has to be in the same directory as srcds_run? look at your script "screen -A -m -d -S......" what do all those things do? for the last time, read the man pages.

you need to figure this out on your own else you're going to have to pay someone to help you, as your next set of questions after you get this running will be "OMG, i can't get mani or any other mods to work please help me!!!!!!"
This is the last thing I’m going to ask you if you want to help answer me if you don’t just ignore.
I placed the file inside the folder where dedicated is installed and now there is one last thing I need, when I enter the
screen -x css-server
command as stated in the srcds tutorial this is what it says:
There is no screen to be attached matching css-server.
Mr.Andy Wrote:
There is no screen to be attached matching css-server.

what do you think it means?
It means what it says i gues, the point is i entered all this commands the way it was said on the tutorial. Please just help me ok?
so if it means what it says, then maybe you don't have a screen session named "css-server"

Forum Jump:

Users browsing this thread: 1 Guest(s)