SRCDS Steam group

sv_downloadurl broken?
Anybody else having a problem with sv_downloadurl not working now? I just added a map to my server earlier without putting it on my client machine and I can't download it now. I tried renaming an older map that I already had on my client also and now I can't get that map either. I run a few linux dedicated servers. -=OTG=- servers if you want to look at it, but it's giving a map not found error and the map is there on the webserver. I've tried it on 2 different webservers that I have space on and neither one works. They were working up until Wednesday nite. I did NOT update the servers until tonite.
Map is located at

When using the sv_downloadurl, you have to mirror the directory structure on the webserver. what does this mean you ask? well, basically, you're going to have this layout;

Then, you put your zipped maps into the map dir. SO, your download url that you posted should actually be;

Ok, apparently I'm totally missing something here or an update hosed me pretty good. I've been running these servers for about 2 years now with the fast download set up without a maps directory and it worked fine. Now I can't get it to work at all. I have an apache server set up for hosting my webpage and hlstats at and and I had the maps hosted by google. It all worked fine up until a week ago. I noticed some people connecting several times but never joining and it was on a new map. I uploaded a brand new custom map and tried to join the server and was not able to get the map myself. Last week was the first time I've ever had a problem with sv_downloadurl not working right.
I've since added all of my maps to to try it from there. It doesn't work! What I'm getting at is, is sv_downloadurl broken or not? It doesn't work on mine and I've now seen it on a couple other servers. Anyone have a fix for it?

Forum Jump:

Users browsing this thread: 1 Guest(s)