SRCDS Steam group

Garry's Mod 9 Server
OK so, first off, I'm running a Garry's mod 9 server. I have been for about a year now, and i'm having severe problems with it. I guess I made the mistake of using hldsupdatetool to update "garrysmod" and it tried to install gmod10 files into my gmod9 folder? but i'm not sure. Does anyone know where i can find a solid update for my gmod9 server that won't kill it? I don't know what exactly was updated in hlsdupdatetool, but it obviously didn't help.

Thanks guys.

well I reinstalled the entire server using armpits Ultimate Dedicated Server, and now it runs nicely, but one odd thing happens... I can't see it on the server lists, and i can't connect manually. When i type "status" into the console, it gives me nothing.
the last message i get is the net_status message, which is usually somewhere in the middle.

NOW what the hell do i do?
Update again!

I finally got it working to a point where it would show info when I said "status" etc. BUT, I now have another entirely random problem. It says the server is out of date, so I do the obvious and update it. It downloads 2 files, I run it, still out of date. I update again, downloads 4 files this time, still out of date though. I think i'll keep updating it until it stops downloading files, then see what happens. Otherwise, I'm screwed.



ok i finally got it working to a point, but now it's back to where it was from the beginning. Anyone that tries to join gets a message telling them they don't have the game.... What in the world is that supposed to mean?
I'd really appreciate some help here...
Heck I'm even willing to VIP anyone who helps me.


I fixed my server to a point. I can now go on it and use it like any other server, but it seems to be stuck in lan mode. I set sv_lan to 0, I forwarded the port, I checked everything that I know of, but it is STILL stuck in lan.

Would someone PLEASE help me?!?!
Seriously... I feel like I'm being purposely ignored here...

Forum Jump:

Users browsing this thread: 1 Guest(s)