SRCDS Steam group

AssertPreCondition error
I am getting the following error when I try to update my css server

Using AMD-Opteron (64 bit) Optimised binary.
Enabling debug mode
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...

Name: NonNullFilePath
Expr: !sFile.empty()
Line: 334
File: ../../../Common/Misc/FileUtil.cpp
/opt/CSS/goldeneye/srcds_run: line 297: 30364 Aborted                 (core dumped) $CMD -game "$GAME"

It only occurs when I update as my css user I have setup. When I run as root, the error does not occur. I am able to run the server, but updating requires running as root, which is a pain.

I am running gentoo as my distro and I haven't updated anything that I can think of that would have affected this.
try to remove the "-autoupdate" from startup
and update it manually

./steam -command update -game "Counter-Strike Source" -dir /home/$USER/$INSTALLDIR
Linux IsiX 64 Generic Desktop ValHalla x86_64
Intel Core 2 Duo T8400 4Gb Ram 40G SSD Intel
[Image: b_460x42_C000000-454234-696149-FFFFFF-FFF468-FFF468.png]
DoD 31 Comunity DoD 31 Spanish Comunity
Erste SS Panzer Grendier Division [DOD Clan]
I forgot to mention that it also fails that way. It fails when doing a complete re-install as well. Only works when logged in as the root user.
can I poke this as I am having this problem on 2 of my dedicated servers but not the other 2 - it is very odd as they are all using the same and wont manually update either NOR will it work through route :S
ok found a get round but not a solution - i cant run it as root but i can run it as users....this is all fine for now but when it fails for users i will be stuffed...any solutions?
I noticed you are using the /opt directory Soynuts, I wonder if that could be the problem.

Have you tried installing to a user home directory?

Forum Jump:

Users browsing this thread: 1 Guest(s)