SRCDS Steam group

Command Line Interface for a WAN Server?
I dl'ed SRCDS and when I start a dedicated server, it keeps stating that it's a LAN Server despite changing sv_lan to 0 (sv_lan 0)

I'll type this into 'Run' (Start>Run)
d:\srcds\srcds.exe -console -game cstrike +map cs_assault -maxplayers 24
and it'll say it's a LAN server

if I try:
d:\srcds\srcds.exe -console -game cstrike +ip +map cs_assault -maxplayers 24
It'll give me this error in console:
then a popup message appears:
|Engine Error                                             |
| Couldn't allocate dedicated server UDP port  |
|                      __________                       |
|                      |     OK     |                       |

Then srcds will shutdown.

Can anyone help me out?
You can't use +ip with your external IP address unless the PC is directly connected to the Internet.  

If the machine's behind a firewall or NAT, the way you make it visibile to the outside world is with port forwarding.
The machine i'm using isn't directly connected to the internet.
I'm not behind any router but I do have a Hub on my network.
How do I forward ports?
A hub is low cost, but it does not discriminate between data source and data recipient. It will send information to all it's ports. It's like a cable splitter. It does not filter data which is sent through it. A hub is an inexpensive way to split an internet connection to 2 or more computers.

Because of this, you should only have to use +ip with nyour LAN ip address the hub assigns you.

so here is what is going to happen:

Your computer will start the srcds dedicated server using your LAN ip. people that connect to your WAN ip will send data to the hub and the hub will direct the incoming data to every computer that is connected. Your computer will be the only one accepting each bit of data while the others will just drop the data. I am not sure how well the server will perform under this situation, but i think a router would work best.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.

Forum Jump:

Users browsing this thread: 1 Guest(s)