SRCDS Steam group

Players cant download files
This didn't used to happen, but now all of a sudden people cannot download anything from me if they don't have the files. Yes, sv_allowdownload/upload are set to 1, and I am using sv_downloadurl which is set to the proper dir. And yes, these are the exact config files that worked great on the windows one, but now all of a sudden, it just doesn't work in linux. Ideas?
Are you able to access the sv_downloadurl through a web browser? That is the best test to make sure the link is working and that the read permissions of all the files are set correctly. It might just be an issue of where the global read permission is not set. Oh, also remember that you have to add the +x permission to directories or you won't be able to go into them through http.
I am able to download them through the browser, yes. The same thing happens if I take out sv_downloadurl. And yes, the +x permissions are set correctly as well, considering that the host hasn't changed its settings since I had the windows srcds, and it worked then. DO you think that it is just an issue with linux? If so, since the permissions are enabled for everyone to use, what else might the problem be? It did at one time work with linux.
It definitely shouldn't be giving that error even when you remove sv_downloadurl. Are user permissions correct? IE, did you install CSS with root but then ran the server with another user? Check and make sure all the files are associated with the user and/or group you want to run the server on. Easy way to set them all is to just go to the base dir and do

chown -R username . && chgrp -R groupname .

Another test would be to run the server as root briefly and see if you still have download problems even with sv_downloadurl off.
I had originally, (before reinstalling knoppix, formatting etc) was dumb enough to download the files as root, and run it with another user. I did the chown thing first though... And it worked then. I'll try doing the chown now and turn sv_downloadurl off. I'll post another reply stating what happened. Smile
Nope, no go. I tried everything you had said. Any other ideas?
have u installed anything on your network which might affect the routing capablities of the ports to the server you are hosting your files from?

give us the URL that you put in your config file, if we cant access it we know its your http server for sure, if we can then we know its your srcds for sure
Like I had said, it does it with or without the sv_downloadurl..... So its obviously not being caused by the url. Secondly, only ssh and apache are running in the backgound, which were running before when it was working.
Only other thing I can possibly think of is that global read permissions on your custom files are not set. I have encountered where custom files I uploaded did not retain those read permissions and I had to set them. Double check the custom files you uploaded and make sure their permissions are correct (this includes making sure custom folders are also given the execute permission). The folder /cstrike/materials may be set to +x and all the default folders as well and thus you see them. However, /cstrike/materials/custommap_materials may not be set with +x and you may not notice because all the other folders are showing up.

Another test that might be good is to delete a common map from your personal steam folder, like de_dust2 and see if the server sends it to you when you connect. (hopefully steam itself doesn't try downloading it for you as an "update") If de_dust2 does send, then you do have permissions not set.
Wow, I had to go about some very obscure way to get this to work. Bear in mind... the KDM is shutdown, so I am using putty. I had to su to root, then couldn't use nohup, had to use the screen -R cstrike command, and hit ctrl a, then ctrl d to detatch. Argh, hell. Anyway, it works now. If you like scoutzknivez, here's my server, Happy fragging! Toungue

Forum Jump:

Users browsing this thread: 1 Guest(s)