SRCDS Steam group

srcds + hlsw + cisco redirect
I've got some problems using HLSW with srcds server behind router Cisco 2611XM.

HLSW ERROR: Connection failed (No connection could be made because the target machine actively refused it. )

SRCDS stands in LAN ( with IP, all port are redirected (270xx UDP, 713x UDP, 1200 UDP, 2703x TCP, etc.). On the same machine there is also HLDS and everything works fine.

I tried with:

"logaddress_add <my workstation Internet IP>:7130"

but it only sends log output what is going on while i still can't control srcds with rcon command...

srcds start like this:

./srcds_run -console -game cstrike +map de_dust +exec server.cfg +maxplayers 14 -autoupdate -port 27017 +ip

(without +ip ... the same error)

On Cisco router i'm using redirect like this:

ip nat inside source static udp 27015 27015 extendable

Got any ideas ?

It should work with that Cisco conf.
in your autoexec try add this

// Logging
log on
logaddress_add **.**.**.**:7130

This works for me anywayz

Sprinter Wrote:tried with:

"logaddress_add <my workstation Internet IP>:7130"

I already wrote that tried with this...

When i'm trying to control my server from another LAN machine (ie., there is no problem, but when i'm getting the log from Internet there is an error message.

logaddress sends log to my internet workstation (I see what people are saying, who killed who, etc.), but still I can't execute any rcon commands with this error message upwards...

log ofcourse is turned ON
ahhh, soz.. must begin read the whole post Big Grin
Anywayz,, i think you should leave out the "extendable" in the syntax, i don't really remember but i think the "extendable" makes cisco use more then the specified port, so try make the syntax like this :
ip nat inside source static udp 27015 27015 <cr>
I think that will help,, but i may have to test it Smile sitting in a Cisco enviroment here, working as a cisco-tech. Rolleyes
2611XM adds automatically "extendable" option.

While typing:

2611(config)#ip nat inside source static udp 27015 27015

router adds:

ip nat inside source static udp 27015 27015 extendable

But i don't think it causes the problem, HLDS on the same machine accepts rcon commands from Internet...
Kuznia Counter-Strike
ahhh, ok,,,
I will run some tests and get back if i can fix the problem Smile
Hopefully i can find something out,, just noticed that i having the same prob on my second server Smile
I've been working on it for a couple days and... nothing.

Hope You find something Smile
Kuznia Counter-Strike

Forum Jump:

Users browsing this thread: 1 Guest(s)