SRCDS Steam group

No connection to master server.
I have installed HLDS on my linux and am trying to run it as a test user (user38) but I run into this problem.

When run: ./hlds_run -game dod -debug

Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Auto-restarting the server on crash

Console initialized.
scandir failed:/home/user38/hlds_l/./platform/SAVE
Protocol version 47
Exe version (dod)
Exe build: 20:06:55 Mar  7 2006 (3421)
STEAM Auth Server
couldn't exec language.cfg
Server IP address
couldn't exec listip.cfg
couldn't exec banned.cfg

It hangs after the last line...forever and never does that connect/authenticate with steam servers which gets you listed on the steam server browser, it just never happens.

I have a static IP and a DMZ set on my router for my linux box and have only been able to connect and get listed once about 3 days ago.

I have also tried an hlds update. Any ideas?
This WHAT should be showing up after the exec commands:

Adding master server
Adding master server
Connection to Steam servers successful.
VAC secure mode is activated.

But it never does, just seems to hang.
Is that the whole command you are starting hlds with?
Quote:./hlds_run -game dod -debug

If so, try adding "+map" and "+maxplayers" with appropriate values to the command. Without map and maxplayers, I think it'll stall right there.
Candy-man thanks. I thought it would fall back to some default value, such as a default start map or server slots, that was the problem.

Thanks a bunch for helping me during my memory lapse!
I am trying to run it using the -pidfile command but it creates the pidfile in /home/username

instead of /home/username/hlds_l

I have tried using it like this: -pidfile /home/username/hlds_l/

No success, any ideas how to get it to create the pid file in another directory besides user's home?
Any help with using the -pidfile option?

Forum Jump:

Users browsing this thread: 1 Guest(s)