SRCDS Steam group

Problem: [...] (core dumped) $HL_CMD
hey guys,
i tried to put up a hl2 deathmatch server and have major problems getting it to work.

when i execute the script i get this:

l3m@xxx:~/srcds> ./srcds_run -game hl2mp -debug
Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Auto-restarting the server on crash
./srcds_run: line 426: 21437 Ungültiger Maschinenbefehl  (core dumped) $HL_CMD
email debug.log to
Mo Mai 29 19:12:34 CEST 2006: Server restart in 10 seconds
Mo Mai 29 19:12:38 CEST 2006: Server Quit

i have read through the posts, i have updated etc etc but i just can't get it to work.

my system info:
gcc --version
gcc (GCC) 3.3.1 (SuSE Linux)

ldd --version
ldd (GNU libc) 2.3.2

uname -a
Linux xxx 2.4.21-303-athlon #1 Tue Dec 6 12:24:00 UTC 2005 i686 athlon i386 GNU/Linux

thanks for your help in advance

So I finally found a solution for my problem: I installed a previous version of the server I found.

It is just a rollback that you can download from here.
Courtesy of

Backup your ./bin Directory so you can undo everything. Then upload the files from the rar into your ./bin (the bin is that from srcds, just incase).

try to start the server...voilá...worked for me.

i had fixed also a rollback patch, if you need: Rollback

but two days later they have fixed the problem and updated the binaries. so you can update your server to the lastest version ...
Linux IsiX 64 Generic Desktop ValHalla x86_64
Intel Core 2 Duo T8400 4Gb Ram 40G SSD Intel
[Image: b_460x42_C000000-454234-696149-FFFFFF-FFF468-FFF468.png]
DoD 31 Comunity DoD 31 Spanish Comunity
Erste SS Panzer Grendier Division [DOD Clan]

Forum Jump:

Users browsing this thread: 1 Guest(s)