SRCDS Steam group

Problem on FreeBSD 5.3 after source upgrade
I had CS:S running on my FreeBSD 5.3 server without problems.
After restarting the server the source dedicated server files were upgraded to version 59.
After that it wouldn't start.
The error message is "Unable to determine CPU Frequency".
I've tried using -binary srcds_i686 but this won't help. Any clues ?

srcds_run output :

Auto detecting CPU
Using SSE2 Optimised binary.
Auto-restarting the server on crash
Unable to determine CPU Frequency

Turns out that the CPU frequency is gathered from the file /proc/cpuinfo which is not present in FreeBSD. Copying a cpuinfo file from a Unix system solved the problem.
I'm having the same problem. Would you mind posting your cpuinfo file? I can collect the necessary info from /var/run/dmesg.boot but I have no idea how this /proc/cpuinfo file should be formatted.
from the steam forums:

Just a note. If you started getting "Cannot determine CPU Frequency" messages on srcds startup. Add the following line to your fstab file:

linprocfs /usr/compat/linux/proc linprocfs rw 0 0

or use the mount_linprocfs command to manually mount the linux process filesystem. The cpuinfo directory in this filesystem is needed to provide srcds with information it needs. Should have set up my linux emulation properly ther first time!
I know exactly how to fix this, WHY NOT JUST USE THE OPERATING SYSTEMS SRCDS WAS MADE FOR AND STOP TRYING TO EMULATE IT ON BSD! simple done and solved Big Grin
BSD is the best OS for webserver but not for gaming servers.

Linux IsiX 64 Generic Desktop ValHalla x86_64
Intel Core 2 Duo T8400 4Gb Ram 40G SSD Intel
[Image: b_460x42_C000000-454234-696149-FFFFFF-FFF468-FFF468.png]
DoD 31 Comunity DoD 31 Spanish Comunity
Erste SS Panzer Grendier Division [DOD Clan]

Forum Jump:

Users browsing this thread: 1 Guest(s)